Ankündigung

Einklappen
Keine Ankündigung bisher.

Keine / keine konsistenten Fehlermeldungen... komisch

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Keine / keine konsistenten Fehlermeldungen... komisch

    ich meine:

    Mein System zeigte mir zuerst gar keine Fehlermeldungen an, dann habe ich ERROR_REPORTING ON gesetzt, zur Sicherheit auch noch 'display_errors' in der php.ini.

    In meiner Hauptdatei mache ich einen Fehler, lasse z.B das Semikolon weg, prompt bekomme ich eine Fehlermeldung im Browserfenster. Super.
    Wenn ich das in einer meiner inkludierten Dateien mache, zeigt mein Browser gar nichts mehr an, das Fenster wird einfach nur weiss. - Keine Ausgabe.

    Kann mir da einer weiterhelfen, woran das liegen könnte??

    ich arbeite/versuche/spiele auf
    Mac OS X, mit MAMP von webedition,
    php4 oder php5, bei beidem gleiches problem

    Vielen Dank im voraus
    Flo


  • #2
    Zur Laufzeit das Error-Reporting handeln ist in sofern problematisch, da zur Laufzeit Fehler auftreten die das Skript-Konstrukt "kaputt" machen können und damit auch die Anweisung, wie mit Fehlern umgegangen wird.

    Das ist wie ein Boot aufm Wasser bauen...

    Am besten alles vor Laufzeit in der php.ini festlegen.

    Kommentar


    • #3
      Poste mal den Code der beiden Dateien.

      Kommentar


      • #4
        moment, versuche gerade, das problem mal "in klein" nachzubauen. kommt bald - bin kein profi

        Kommentar


        • #5
          Ok, ich versuchs mal. Insgesamt verwirren mich drei Dateien:
          - index2.php - klar, darum gehts...
          - startup2.inc.php - hier will ich mal all jene sachen reinpacken, die ich zum Starten brauche
          - config2.inc.php - vorerst die konfiguration

          index2.php
          PHP-Code:
          <?php
          echo "
           Start des testes
          "
          ;    

          include(
          "includes/startup2.inc.php"); //Die ganzen Start-Einstellungen
          include ("includes/config2.inc.php"); // Konfiguration

          echo "Hallo ---   test in der index2.datei";    
          echo 
          "
          "
          ;
          ?>
          dann erstmal aufruf der startup2.inc.php:
          PHP-Code:
          <?php
                  ini_set
          ('display_errors',TRUE);
              
          ini_set('display_startup_errors',TRUE);
              
          error_reporting('E_ALL'); //fehler sollen angezeigt werden
              
          error_reporting('E_STRICT');
              
          error_reporting('E_USER_NOTICE');    

              
          //include ("includes/config2.inc.php"); // Konfiguration    
              
          include("includes/allgemein.inc.php"); // allgemeinere funktionen

              
          echo "
          test in der startup2.inc!! 
          "
          ;    
              echo 
          "
          "
          ;
          ?>
          anschliessend include ich die config2.inc.php, in diesem Beispiel aus der Index2 heraus....
          PHP-Code:
          <?php
          echo "Test in der config2.inc. !!"    //Hier fehlt ein Semikolon !!!!
          echo "
          "
          ;
          ?>
          So, ich habe jetzt mal alles etwas runtergebrochen, ich weiss aber immer noch nicht woran es liegt. Die Ausgabe dieser Skripte führt zu:

          PHP-Code:
          Start des testes

          test in der startup2
          .inc!! 
          Die Ausgabe aus der config2.inc.php erscheint nicht mehr, auch kein Parse Error, oder irgendwas...

          in der php.ini habe ich schon was verstellt, error_reporing steht auf 2047.
          Ich habe schon etwas mit der Rehienfolge der includes gespielt,
          - wenn ich erst die config2.inc aufrufe, scheint es etwas besser zu gehen,
          - Fehler (Fehlende Semikola) in der startup2.inc werden als Parse Error ausgegeben

          Hat einer von Euch einen Fehler entdeckt, oder kann mir einen Tip geben??
          Danke im voraus

          Kommentar


          • #6
            Mit error_reporting('E_ALL') deaktivierst Du die Fehlerausgabe ((int) 'E_ALL' == 0).

            Es handelt sich bei E_ALL um eine vordefienierte Konstante also ist error_reporting(E_ALL) korrekt.

            Dann noch die weiteren Aufrufe von error_reporting() entfernen und fertig... :wink:

            Kommentar


            • #7
              cool, soweit klappt das schon deutlich besser , ist das für php4 und php5 identisch?
              (ja, ich habe gerade das Handbuch gecheckt, aber ich kann mich dunkel an eine fehlermedlung alà 'E_ALL' erinnern - daher kam meine Verwirrung.... )

              Super vielen Dank, mal sehen wie's weiter geht
              flo

              Kommentar

              Lädt...
              X