Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit Variablen Uebergabe

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem mit Variablen Uebergabe

    Hallo,
    ich habe folgendes Problem:
    egal welchen Wert ich nun eingebe, die php Datei gibt mir immer 0.16 aus, ich denke es liegt daran, das keine Werte der Variablen �bergeben werden, bzw die Variable brutto warum auch immer "0" gesetzt wird.
    Wei� irgendwer Rat an was das liegen k�nnte?
    THX
    HTML:
    <body>
    <form action="Blatt12.php" method="post" target="">
    Geben sie ihren Bruttobetrag ein: <input type="Text" name="brutto">
    <input type="Submit" name="" value="Absenden">
    PHP:
    <?
    $mwst=$brutto+0.16;
    $netto=$mwst+brutto;

    echo "$netto";
    ?>


  • #2
    $netto=$mwst+brutto;

    bei brutto fehlt ein $
    Wie man Fragen richtig stellt

    Kommentar


    • #3
      Und schon wieder register_globals:

      11.20. Warum funktionieren meine Formulare nicht?
      http://faq-phpfriend.de/q/q-formular...r-globals.html

      http://www.php.net/manual/de/security.globals.php

      Gruß
      phpfan

      Kommentar


      • #4
        @phpfan, heute so hilfsbereit? warum den User nicht zuerst debuggen lassen?
        Wie man Fragen richtig stellt

        Kommentar


        • #5
          Zitat von dsmcg
          @phpfan, heute so hilfsbereit? warum den User nicht zuerst debuggen lassen?
          Bei der MwSt-Berechnung kommt das noch.

          Gruß
          phpfan

          Kommentar

          Lädt...
          X