Ankündigung

Einklappen
Keine Ankündigung bisher.

Verbindung zur MySQL-DB bei Strato per PHP ???

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Verbindung zur MySQL-DB bei Strato per PHP ???

    Morgen

    Hab ein kleines Prob....ich wollte (wegen eines anderen Problems das ich habe) eine Datenbank und meinen PHP-Code auf meinen Webspace bei Strato laden. Nach unzähligen versuchen mit telnet und so hab ich zumindest das geschafft. Jetzt versuche ich noch eine Verbindung zur DB herzubekommen. Nur schaffe ich das irgendwie nich...bekomme immer diese Fehlermeldung (und das gleich mehrmals)...


    Warning: Unknown MySQL Server Host 'rdbmsstratode' (0) in /mnt/kw1/08/925/00000000/htdocs/projekt/auswahl_kurs.php on line 27


    Mal angenommen...der Name meiner DB wäre DB0815, der Username U0815, das Passwort Tauchsieder (alles wie gesagt nur fiktiv)...wie müsste dann eine verbindnug zu Strato aussehen ?

    Hab schon dieverse Sachen aus dem Netz versucht...aber nichts hat geklappt. Das ganze funzt lokal, nur halt ohne Host und so, aber an der DB-Abfrage kann es nicht liegen...

    Besten dank

    Lapje


  • #2
    rdbms.strato.de

    Kommentar


    • #3
      eben nicht..das habe ich auch schon versucht...und trotzdem bekomme ich keine Verbindung...irgendwas läuft da falsch...

      Kommentar


      • #4
        und "localhost"?

        Gerade nachgeschaut, ich verbinde bei einem Projekt mit folgenden Daten erfolgreich:

        HOST:
        rdbms.strato.de

        DB:
        DB0815

        USER:
        U0815


        mysql_connect(HOST, USER, PW);
        mysql_select_db(DB);


        Klappt einbahnfrei

        Kommentar


        • #5
          warum funzt das bei mir dann nicht??? hab das genauso gemacht...

          Oder kann ich irgendwie rausbekommen ob die DB überhaupt online ist ? Vielleicht liegt es daran...

          Hab jetzt so verbdunden:
          // Verbindung zur Datenbank wird hergestellt
          mysql_connect(rdbms.strato.de, U10815, limonade);
          mysql_select_db(DB0815);


          und bekomme immer noch die Meldung:

          Warning: Unknown MySQL Server Host 'rdbmsstratode' (0) in /mnt/kw1/08/925/00000000/htdocs/projekt/auswahl_kurs.php on line 27


          menno...

          Kommentar


          • #6
            Kann sonst keiner helfen ?

            Kommentar


            • #7
              Zitat von Lapje
              Kann sonst keiner helfen ?
              Doch, die Strato-Hotline oder eventuell deren FAQ.

              Gruß
              phpfan

              Kommentar


              • #8
                Haaaaaaaaaahahahahaaahahahaaaaaa....

                So schlau war ich auch schon.. So wie ich es mache steht es ja in den FAQ's...nur hab ich im Netz gelesen dass diese selber nicht mehr auf dem neusten Stand sein sollen....

                Kommentar


                • #9
                  Zitat von Lapje
                  Haaaaaaaaaahahahahaaahahahaaaaaa....
                  So schlau war ich auch schon.. So wie ich es mache steht es ja in den FAQ's...nur hab ich im Netz gelesen dass diese selber nicht mehr auf dem neusten Stand sein sollen....
                  Nicht Hahaha, rufe die Hotline an, die werden dir das sagen können! So schlau warst du nun auch wieder nicht.

                  Gruß
                  phpfan

                  Kommentar


                  • #10
                    war auch eher ironisch gemeint..

                    Kommentar


                    • #11
                      Zitat von Lapje
                      Warning: Unknown MySQL Server Host 'rdbmsstratode' (0) in /mnt/kw1/08/925/00000000/htdocs/projekt/auswahl_kurs.php on line 27
                      Das ist auch falsch. Poste hier nicht falschen Code, sondern Code von dem du wenigstens annimmst, dass er richtig ist. Aber der Host is definitiv falsch.

                      Ich vermute ja du übergibst die Parameter nicht mit Anführungszeichen, weswegen aus rdbms.strato.de ein rdbmsstratode wird ^^

                      Kommentar


                      • #12
                        Wieso falscher Code ? Das ist die Fehlermeldung die ich bekomme...da kann ich doch nix für..

                        Was ich nur nicht verstehe...ist das normal das oben auch das Verzeichnis "htdocs" kommt ? Ich habe alle snoch mal überprüft, alle Links sind relative pfade...

                        Und was mir noch aufgefallen ist (kann aber auch normal sein) das der Host rdbms.strato.de sein sollte, bei der Fehlermeldung wird er aber als rdbmsstrato.de (also ohne ". ") angegeben. Ist das auch ok so ?

                        Lapje

                        Kommentar


                        • #13
                          In meinem Posting oben, letzter Satz, steht die Lösung

                          Kommentar


                          • #14
                            C:\Dokumente und Einstellungen\Besitzer>ping rdbmsstrato.de
                            Ping-Anforderung konnte Host "rdbmsstrato.de" nicht finden. Überprüfen Sie den N
                            amen, und versuchen Sie es erneut.

                            C:\Dokumente und Einstellungen\Besitzer>ping rdbms.strato.de

                            Ping rdbms.webmailer.de [192.67.198.61] mit 32 Bytes Daten:

                            Antwort von 192.67.198.61: Bytes=32 Zeit=36ms TTL=244
                            Antwort von 192.67.198.61: Bytes=32 Zeit=36ms TTL=244
                            Antwort von 192.67.198.61: Bytes=32 Zeit=37ms TTL=244
                            Antwort von 192.67.198.61: Bytes=32 Zeit=36ms TTL=244

                            Ping-Statistik für 192.67.198.61:
                            Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
                            Ca. Zeitangaben in Millisek.:
                            Minimum = 36ms, Maximum = 37ms, Mittelwert = 36ms
                            scheint nicht ok ... aber wie vorher schon erwähnt der rdbms.strato.de sollte laut ping funktionieren.
                            schlimmer gehts nimmer.... dümmer immer!

                            Kommentar


                            • #15
                              aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaahhhhhhhh hhhhhhhhhhhhhhhhh....ok...werds mal versuchen...ich dummchen....

                              besten dank

                              Kommentar

                              Lädt...
                              X