Ankündigung

Einklappen
Keine Ankündigung bisher.

Oracle probleme beim einbinden der php_oci8.dll

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Oracle probleme beim einbinden der php_oci8.dll

    Hallo

    Ich bekomme es nicht hin die php_oci8.dll erfolgreich einzubinden.
    Orakel 8 ist bei mir instaliert.
    PHP 4.1.2
    IIS 5.2

    In dem Ordner Extensions ist die DLL vorhanden.

    Ich habe in der ini folgendes geändert.

    Code:
    ; Directory in which the loadable extensions (modules) reside.
    ;extension_dir = ./
    extension_dir = "C:\PHP\Extensions"
    
    
    
    
    ;Windows Extensions
    ;Note that MySQL and ODBC support is now built in, so no dll is needed for it.
    ;
    ;extension=php_bz2.dll
    ;extension=php_ctype.dll
    ;extension=php_cpdf.dll
    ;extension=php_curl.dll
    ;extension=php_cybercash.dll
    ;extension=php_db.dll
    ;extension=php_dba.dll
    ;extension=php_dbase.dll
    ;extension=php_dbx.dll
    ;extension=php_domxml.dll
    ;extension=php_dotnet.dll
    ;extension=php_exif.dll
    ;extension=php_fbsql.dll
    ;extension=php_fdf.dll
    ;extension=php_filepro.dll
    ;extension=php_gd.dll
    ;extension=php_gettext.dll
    ;extension=php_hyperwave.dll
    ;extension=php_iconv.dll
    ;extension=php_ifx.dll
    ;extension=php_iisfunc.dll
    ;extension=php_imap.dll
    ;extension=php_ingres.dll
    ;extension=php_interbase.dll
    ;extension=php_java.dll
    ;extension=php_ldap.dll
    ;extension=php_mbstring.dll
    ;extension=php_mcrypt.dll
    ;extension=php_mhash.dll
    ;extension=php_ming.dll
    ;extension=php_mssql.dll
    extension=php_oci8.dll
    ;extension=php_openssl.dll
    ;extension=php_oracle.dll
    ;extension=php_pdf.dll
    ;extension=php_pgsql.dll
    ;extension=php_printer.dll
    ;extension=php_sablot.dll
    ;extension=php_shmop.dll
    Der Pfad ist auch richtig ich bekomme voldende Fehlermeldung
    "Unable to load dynamic library 'C:\PHP\Extensions/PHP_oci8.dll' - Die angegebene Prozedur wurde nicht gefunden"

    MFG
    Andre


  • #2
    Und die Einstellung für extension_dir ist auch richtig?

    Kommentar


    • #3
      ja

      Kommentar


      • #4
        php_oci8.dll ist abhängig von oci.dll aus der Clientinstallation.

        http://de2.php.net/oci8
        You will need the Oracle client libraries to use this extension. Windows users will need at least Oracle version 8.1 to use the php_oci8.dll dll.

        The most convenient way to install all the required files is to use Oracle Instant Client, which is available from here: http://www.oracle.com/technology/tec...antclient.html. Instant Client does not need ORACLE_SID or ORACLE_HOME environment variables set. You still may need to set LD_LIBRARY_PATH and NLS_LANG, though.

        Kommentar


        • #5
          die oci.dll befindet sich auch in dem Extensions verzeichniss es geht aber trotzdem nicht!

          Oder muss ich die irgendwo in der PHP ini einbinden?

          Kommentar


          • #6
            muss der pfad (auch wenn es eine Windows-Kiste ist) nicht so aussehen:

            Code:
            C:/PHP/Extensions
            und versuchs mal mit einem "/" oder halt "\" wen es wirklich ein "\" ist an den schluss zu setzen
            Wie man Fragen richtig stellt

            Kommentar


            • #7
              Zitat von diskus99
              die oci.dll befindet sich auch in dem Extensions verzeichniss es geht aber trotzdem nicht!

              Oder muss ich die irgendwo in der PHP ini einbinden?
              Da wird sie Windows vermutlich nicht finden.
              Verschieb oci.dll mal in das Windowsverzeichnis.

              Kommentar


              • #8
                Code:
                C:\PHP\Extensions/PHP_oci8.dll'
                der schreibt nach dem Ordner extension ja automatisch ein "/"

                und wenn man den apache auf ner Windowskiste konfiguriert muss man ja auch bei Pfad angaben mit / arbeiten

                hmm so wies ausschaut verstehe ich da was falsch.. na ja ist ja auch egal, ich halte mich jetzt mal daraus
                Wie man Fragen richtig stellt

                Kommentar


                • #9
                  Ich habe die OCI in c:\Windows kopiert

                  Geht auch nicht!!

                  mit "\" oder "/" ändert sich auch nichts immernoch die fehlermeldung vom anfang

                  Kommentar


                  • #10
                    Hast Du alle bei http://de2.php.net/oci8 beschriebenen Vorbereitungen durchgeführt?

                    Kommentar


                    • #11
                      ja habe ich.

                      Es hat auch schonmal auf dem Rechner funktioniert aber seit dem ich die andere PHP version instaliert habe funktioniert es nicht mehr.

                      Kommentar


                      • #12
                        Du musst die "DLL" nicht nach C:\Windows kopieren, sondern nach C:\Windows\System32 und dann sollte das auch funktionieren!

                        Gruß

                        MTC

                        Kommentar


                        • #13
                          Ist egal. Windows guck sowohl im System als auch im Windows Vserzeichnis nach.
                          http://msdn.microsoft.com/library/de...arch_order.asp

                          Kommentar


                          • #14
                            es geht immer noch nicht!!!
                            Ich kann die dll nicht im Windowsordner oder in /system32 drin lassen weil sonst meine anmeldung an einer Software die ich dringend in der Firma brauche nicht mehr funktioniert.

                            Gibt es noch andere möglichkeiten. Die dll liegt jetzt wieder im extenjions ordner.

                            Kommentar


                            • #15
                              Lad Dir mal den passenden Dependency Walker bei http://www.dependencywalker.com/ herunter.

                              Entpacken, .exe aufrufen und dann File,Open,php_oci8.dll
                              Werden Fehler angezeigt bei Modulen die in der unteren Liste ohne Sanduhr angezeigt werden?

                              Gehört die php_oci8.dll zur selben PHP Version? Im Zweifelsfall nocheinmal das ZIP Paket für Windows von http://www.php.net/downloads.php laden und php neu installieren.

                              Kommentar

                              Lädt...
                              X