Ankündigung

Einklappen
Keine Ankündigung bisher.

PHP.ini wird nicht gefunden

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHP.ini wird nicht gefunden

    Hallo,

    habe ein kleines Problem mit PHP 5.1.1 und PHPMyAdmin
    Wenn ich PHPMyAdmin aufrufe erschein folgende Fehlermeldung

    Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration. - Dokumentation

    in der PHP.ini habe ich diese Erweiterung aktiviert.

    Das Problem kommt vermutlich daher, das PHP die PHP.ini gar nicht ließt.

    Lt. phpinfo liegt die php.ini unter c:\winnt



    unter C liegt jedoch überhaupt nirgends eine php.ini. Diese liegt direkt im PHP Verzeichnis unter D.

    Testweise habe ich die PHP.ini auch in c:\winnt kopiert, dies ändert jedoch auch nichts.

    Kann mir jemand sagen wie ich PHP 5 mitteile wo seine .ini liegt?

    Auf diesem Server habe ich zusätzlich auch noch PHP4 am laufen dies läuft ohne Probleme und die php.ini liegt hier im php verzeichniss.

    Das PHP Verzeichnis habe ich in der PATH Variablen hinzugefügt.

    Webserver IIS5 (W2k Server SP4 mit IIS Lockdown)
    MySQL 5.0.18
    PHPMyAdmin 2.7.0 pl2


  • #2
    unter C liegt jedoch überhaupt nirgends eine php.ini. Diese liegt direkt im PHP Verzeichnis unter D.
    Da würde php sie halt lesen, wenn da eine wäre. Von daher war Dein nächster Schritt
    Testweise habe ich die PHP.ini auch in c:\winnt kopiert, dies ändert jedoch auch nichts.
    schon richtig. die php-recommended.ini nach c:\winnt kopieren, in php.ini umbenennen und bearbeiten.
    Und dann den IIS neu starten.

    Kommentar


    • #3
      PHP-Code:
      <?
         phpinfo();
      ?>
      Suche in der Ausgabe dieses Scriptes, welche php.ini genommen wird.

      Gruß
      phpfan

      Kommentar


      • #4
        Zitat von phpfan
        Suche in der Ausgabe dieses Scriptes, welche php.ini genommen wird.
        Zitat von quaker
        Lt. phpinfo liegt die php.ini unter c:\winnt

        Kommentar


        • #5
          ok hab wie es scheint nach dem kopieren des php.ini ins winnt verzeichniss den restart des iis vergessen. nun scheint er etwas zu machen

          phpmyadmin läuft aber jetzt erscheint beim aufruf von phpinfo nur noch eine weiße seite???

          wie kann ich php zwingen die php.ini im php verzeichniss zu verwenden?
          unter php4 klappts ja auch

          Kommentar


          • #6
            http://de.php.net/manual/en/configur...iguration.file
            php.ini is searched in these locations (in order):

            * SAPI module specific location (PHPIniDir directive in Apache 2, -c command line option in CGI and CLI, php_ini parameter in NSAPI, PHP_INI_PATH environment variable in THTTPD)

            * HKEY_LOCAL_MACHINE\SOFTWARE\PHP\IniFilePath (Windows Registry location)
            ...
            Aber ich tippe einfach mal auf eine Fehlkonfiguration.

            Kommentar

            Lädt...
            X