Ankündigung

Einklappen
Keine Ankündigung bisher.

Dieses Forum...aber wie?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Dieses Forum...aber wie?

    Ja hallo ich bin es mal wieder. :wink:
    Ich wollte dieses Forum für meine Hp benutzen,
    jedoch komme ich bei der Instalation niht weiter.
    MySQL Server vorhanden.

    Info:
    Verbunden mit MySQL 4.1.14-nt auf localhost als root@localhost

    Nun bekomme ich jedesmal folgende Fehlermeldung.

    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in C:\Programme\xampp\htdocs\gb\db\mysql4.php on line 330

    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in C:\Programme\xampp\htdocs\gb\db\mysql4.php on line 331
    phpBB : Critical Error

    Could not connect to the database


  • #2
    www.phpbb.de ....
    Klick mich


    Kommentar


    • #3
      Da finde ich leider keine Lösung für mein Problem.

      Kommentar


      • #4
        du sollst da im forum fragen weil das hier kein phpbb forum ist.
        Klick mich


        Kommentar


        • #5
          Welche php Version wird benutzt?

          Kommentar


          • #6
            5.x version....werde aber den gleichen Post im anderen Forum erneut posten.

            Kommentar


            • #7
              Zitat von Sausack
              5.x version....werde aber den gleichen Post im anderen Forum erneut posten.
              und du wirst sehen, man wird dir helfen.
              Klick mich


              Kommentar


              • #8
                ...
                Could not connect to the database

                überprüf mal die zugangsdaten für die datenbank...
                so wie es aussieht, kann das script keine verbindung zur datenbank aufnehmen..


                mfg Andi

                Kommentar


                • #9
                  Kann auch am neuen Passwortsystem von mysql liegen.
                  Dem kann man bei php5 abhelfen, indem die vobn php benutzte libmysql auf den Stand der 4.1er Datenbank gebracht wird. Liegt normalerweise dem Mysql Paket bei.

                  Aber eigentlich spuckt mysql dann eine entsprechende Fehlermeldung aus. Und phpbb würde die doch sicherlich weiterreichen .?.

                  Kommentar


                  • #10
                    Datenbank läuft richtig und funktioniert.

                    Da es ja alles nur auf dem Laptop ist habe ich nicht viel zu verheimlichen.


                    Database Configuration
                    Database Server Hostname / DSN: localhost
                    Your Database Name: buch
                    Database Username: root
                    Database Password:
                    Prefix for tables in database: phpbb_

                    Installiert ist xampp falls das jemand kennt.

                    Kommentar


                    • #11
                      Installiert ist xampp falls das jemand kennt.
                      Ja, ist bekannt. Will ich mir jetzt aber nicht auf den Rechner knallen.
                      Du bist Dir sicher, dass
                      - der mysql Server läuft?
                      - es den Benutzer root mit leerem Passwort gibt?
                      Du hast das getestet, indem Du Dich mit einem anderen Programm auf diesen mysql Server als root verbunden hast?
                      Wahlweise auch das Skript
                      PHP-Code:
                      <?php
                      error_reporting
                      (E_ALL); ini_set('display_errors'true);

                      $db mysql_connect('localhost''root''') or die(mysql_error());
                      mysql_select_db('buch'$db) or die(mysql_error());
                      ?>
                      ausprobieren.

                      Kommentar


                      • #12
                        Ja ich bin mir ziemlich sicher das das so past, da ich auch mit anderen Programmen zugreife.

                        Kann das mit PHP5 und PHP4 zusammenhängen?

                        Habe es mit deinem Script gerade getestet und keine Meldung bekommen,also kein Fehler.

                        Kommentar


                        • #13
                          gab mal nen thread über phpbb und php5. use mal die search
                          Klick mich


                          Kommentar


                          • #14
                            Ich konnte das Problem finden.
                            Also ich hatte vorher auch ein selfinstall Script installiert und dort wurde die Datenbank selber angelegt.
                            Bei phpbb muss man das manuell machen.....

                            Ich bedanke mich bei allen die mir helfen wollten.


                            Eine Frage noch.....bedeutet das ich diese Ordner löschen soll?
                            Please ensure both the install/ and contrib/ directories are deleted

                            Kommentar


                            • #15
                              ja.
                              da man darüber mist machen kann.

                              stefan
                              Klick mich


                              Kommentar

                              Lädt...
                              X