Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit einfachem Mail()-Skript

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem mit einfachem Mail()-Skript

    Hi, habe ein kleines Mailscript gefunden, welches aus meinem Kontaktformular mittels Post die Daten erhalten soll, und diese per Mail() versenden soll.

    Mein Problem:
    Ich bekomme (mit Mozilla als Browser) eine Mail die wie folgt aussieht:
    Name:
    Email:
    Telefon:
    Nachricht:
    Submit: Senden
    Ich bekomme also die Titel der Felder, aber nicht deren Inhalt, der nach den ":" folgen sollte. Also als wenn die Werte der Variablen nicht übergeben wurden. Aber mit dem IE als Browser funktioniert es.

    Habt ihr eine Idee?

    Formularcode (Auszug):
    Code:
    <form action="mailit.php" method="post" name="frm_mail1" id="frm_mail1">
      <table width="45%"  border="0">
        <tr>
          <td width="8%" valign="top">Name</td>
          <td width="92%"><input name="Name" type="text" id="Name" tabindex="1" size="40" maxlength="50"></td>
        </tr>
    ...
    ...
    ...
          <td><textarea name="Nachricht" cols="50" rows="10" id="Nachricht" tabindex="4"></textarea></td>
        </tr>
       <tr>
          <td valign="top"></td>
          <td></td>
        </tr>
        <tr>
          <td valign="top"></td>
          <td><label>
            <input name="but_reset" type="reset" id="but_reset" value="Zurücksetzen">
            <input name="but_send" type="submit" id="but_send" value="Senden">
    </label></td>
        </tr>
      </table>
    </form>
    Das mailit.php-Skript (welches mit dem IE funktioniert)
    Code:
    <?php
    $msg = "";
    foreach($_POST AS $key=>$value) {
        $msg .= $key.": ".$value."\n";
    }
    mail("abc@abc.de","Betreff....",$msg,"From: abc@abc.de");
    ?>
    Was muss ich in der Syntax ändern, damit es in allen Browsern läuft?

    Danke schon mal für eure Hilfe...


  • #2
    Was muss ich in der Syntax ändern, damit es in allen Browsern läuft?
    Wieso eigentlich Browser ?
    Deine E-Mails wirst da ja sicher nicht übern IE angucken oder ?

    Bei mailit.php ist eigentlich nichts falsches dran, und geht auch.

    Kommentar


    • #3
      Nein, meine Emails sehe ich mir mit Outlook 2003 an.

      Ich dachte es liegt an einer browserspezifischen Syntax, da ich die Email korrekt angezeigt bekomme, wenn ich mit dem IE surfe und das Kontaktformular ausfülle und abschicke, aber nicht wenn ich das gleiche mit Mozilla mache.

      Habe folgenden Test gerade gemacht:
      Ich habe gerade
      Code:
      	echo($msg."
      ");
      in die Foreach schleife eingefügt um den jeweiligen Stand von der Variablen $msg angezeigt zu bekommen.

      Der IE zeigt die Variablen korrekt im Fenster an, bevor er diese versendet.
      Name: Name 1
      Name: Name 1 Email: email 1
      Name: Name 1 Email: email 1 Telefon: 123456
      Name: Name 1 Email: email 1 Telefon: 123456 Nachricht: Nachricht 1
      Name: Name 1 Email: email 1 Telefon: 123456 Nachricht: Nachricht 1 but_send: Senden
      Der Mozilla aber nur:
      Name:
      Name: Email:
      Name: Email: Telefon:
      Name: Email: Telefon: Nachricht:
      Name: Email: Telefon: Nachricht: but_send: Senden
      Er bekommt also definitif keine Variablen von dem selben Formular.

      Komme also wiederum zu dem Schluss das es auf eine browserspezifische Syntax rausläuft... nur find ich nix zu diesem Problem.

      Kann mal jemand das mit seinem Mozilla prüfen, vielleicht hängt es ja auch ganz "userspezifisch" nur an meinem Mozilla ?-) (siehe http://www.alexk-mainz.de/Linek/index.html unter Kontakt / Email -> Danke .. und vielleicht als Nachricht mit welchem Browser ihr das versendet habt...

      Kommentar


      • #4
        sollte sowas wie eine erfolgsmeldung eingebaut sein, dein script funzt bei mir generell nicht, zumindest sehe ich keinen erfolg oder eine meldung, warum es nicht klappt.
        gruss sys

        Kommentar


        • #5
          siehe http://www.alexk-mainz.de/Linek/index.html unter Kontakt / Email -> Danke .. und vielleicht als Nachricht mit welchem Browser ihr das versendet habt...
          Mozilla Firebird, nur das an der angegebenen Stelle kein Formular existiert?

          Kommentar


          • #6
            Danke fürs testen.. habe die Testmails bekommen. Das Formular / Skript lieferte noch keine Erfolgsmeldung, ich wollte erst mal sehen, das überhaupt eine Mail bei mir ankommt.
            Hab das Problem selber zwar nicht gefunden, aber umgangen. Mittels eines Flashformulars und einem anderen PHP-Skript funktioniert es sowohl in IE als auch Mozilla.

            Da ich die Seite für einen Freund schnell online bringen wollte hab ich es jetzt mit dem Flash gelöst bzw... getestet. Das Flashformular baue ich noch aus, und ne Umleitung nach erfolgreich abgesandter Mail kommt auch noch dazu.

            Danke für euren "Einsatz"
            Auch wenn ich das Problem nicht beheben konnte, sondern nur umgehen *g* Hauptsache es funktioniert.

            Ich werde mich später nochmal mit dem Problem auseinander setzen, wenn die HP fertig ist. Ich glaube es hängt an der Übergabe bzw der globalen Servervariablen $HTTP_POST_VARS bzw wie das PHP skript die Daten annimmt. Ich werde das nochmal testen und meine Lösung hier rein schreiben.

            Kommentar

            Lädt...
            X