Hallo zusammen!

Ich hab ein Problem beim Erstellen eines neuen Datensatzes.

Ich hab ein Formular. Die eingegebenen Werte werden in einer Session gespeichert.
Nach ein paar Schritten kommt man dann zum Speichern.
Und genau hier ist das Problem:

Wenn man auf den Button klickt, dann sollte der Eintrag gespeichert werden und eine dementsprechende Meldung soll angezeigt werden.

Bei diesem Code:
PHP-Code:
<?
// wenn SAVE gedrückt wurde, wird überprüft, ob die Angaben stimmen, wenn ja, dann wird ein neuer Datensatz erzeugt
    if(isset($_POST['SAVE']))
    {
        if(!isset($_POST['GESCHLECHT']))    echo "<font color='red'>[b]Geschlecht fehlt![/b]</font>
";
        else if($_POST['FAMNAME'] == "")    echo "<font color='red'>[b]Familienname fehlt[/b]</font>
";
        else if($_POST['VORNAME'] == "")    echo "<font color='red'>[b]Vorname fehlt![/b]</font>
";
        else
        {
            
            include('include_funktionen.php');
            include('include_javascript.php');
            include('stylesheet.css');
            header("Location: index.php?section=neuer_eintrag&test=update&PHPSESSID=".session_id());

            neuer_eintrag_00($tb_name_02, $tb_name_03);
            
        }
    }
?>
wird das zwar alles gemacht, aber die Meldung erscheint auf einer leeren Seite

bei diesem:
PHP-Code:
<?
// wenn SAVE gedrückt wurde, wird überprüft, ob die Angaben stimmen, wenn ja, dann wird ein neuer Datensatz erzeugt
    if(isset($_POST['SAVE']))
    {
        if(!isset($_POST['GESCHLECHT']))    echo "<font color='red'>[b]Geschlecht fehlt![/b]</font>
";
        else if($_POST['FAMNAME'] == "")    echo "<font color='red'>[b]Familienname fehlt[/b]</font>
";
        else if($_POST['VORNAME'] == "")    echo "<font color='red'>[b]Vorname fehlt![/b]</font>
";
        else
        {
            header("Location: index.php?section=neuer_eintrag&test=update&PHPSESSID=".session_id());
            include('include_funktionen.php');
            include('include_javascript.php');
            include('stylesheet.css');
            

            neuer_eintrag_00($tb_name_02, $tb_name_03);
            
        }
    }
?>
bleibt man zwar auf der Seite (soll so sein), es wird auch alles gespeichert, aber die Meldung kommt nicht

Weiß jemand woran das liegt, bzw wie ich das ändern kann?

Danke im Vorraus für jede Antwort!