Ankündigung

Einklappen
Keine Ankündigung bisher.

[PEAR] PHP läuft - mit PEAR CGI Timeout

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [PEAR] PHP läuft - mit PEAR CGI Timeout

    Hi,

    ich verzweifel noch. Auf einem IIS6 habe ich PHP installiert. Geht auch ohne Probleme. Nun habe ich PEAR installiert. Soweit läuft auch noch alles.

    Dann nutze ich in meinem PHP Script DB_PEAR und es kommt dieses CGI-Timeout

    Was könnte das sein?

    Mein include PATH ist richtig gesetzt sonst würde er ja einen anderen Fehler bringen..

    Hülfe =)


  • #2
    Skriptcode?

    Kommentar


    • #3
      ganz normal..

      PHP-Code:
      <?php
      require_once ('DB.php');

      function 
      connect()
      {
          
      $conn "mssql://sa:xxx@xxx.xxx.xxx.xxx/DB";
          return 
      $conn;
      }

      $conn connect();
      $db DB::connect($conn);

      if(
      DB::isError($db))
      {
          die(
      $db->getMessage());
      }

      $sql "select num_evt_count
              from num_numEvent"
      ;
      $result $db->query($sql);
      $row $result->numRows();

      echo 
      "Die Zahl: ".$row;
      ?>
      vielleicht noch etwas, der db-server ist nicht local sondern wo anders.. auf den db-server greifen aber schon mehrere skripte von aussen zu also an dem kann es nicht liegen.. denke ich zumindest..

      Kommentar


      • #4
        Deine Funktion connect() verbindet garnicht, sondern liefert nur die entsprechende Zeichenkette; verwirrend.

        Ohne Debugger leistet oft ein printf-Debugger erste Hilfe. Auch wenn es fummelig und selbst fehleranfällig ist.
        PHP-Code:
        <?php
        require_once ('DB.php');

        function 
        connect()
        {
           
        $conn "mssql://sa:xxx@xxx.xxx.xxx.xxx/DB";
           echo 
        "

        Start DB::connect</p>\n"
        flush();
           
        $db DB::connect($conn);
           echo 
        "

        Ende DB::connect</p>\n"
        flush();
           return 
        $db;
        }

        echo 
        "

        Verbinden</p>\n"
        flush();
        $db connect();
        echo 
        "

        Start DB::isError</p>\n"
        flush();
        if(
        DB::isError($db))
        {
           die(
        $db->getMessage());
        }
        echo 
        "

        Ende DB::isError</p>\n"
        flush();

        echo 
        "

        Start query</p>\n"
        flush();
        $sql "select num_evt_count from num_numEvent";
        $result $db->query($sql);
        echo 
        "

        Ende query</p>\n"
        flush();

        echo 
        "

        Start numRows</p>\n"
        flush();
        $row $result->numRows();
        echo 
        "

        Ende numRows</p>\n"
        flush();

        echo 
        "Die Zahl: ".$row;
        ?>

        Kommentar


        • #5
          Zitat von Bruchpilot
          Deine Funktion connect() verbindet garnicht, sondern liefert nur die entsprechende Zeichenkette; verwirrend.
          stümmt.. verwirrend - sorry


          er kann nicht verbinden bzw. steigt er an dieser stelle aus.. habe da aber eine idee..

          mom =)

          Kommentar


          • #6
            dachte es liegt an der ntwdblib.dll die nicht auf dem server war.. jetzt hab ich sie dahin kopiert aber immer noch nicht besser folgende ausgabe erhalte ich

            Code:
            Verbinden
            
            Start DB::connect
            also hängt er da irgend wo.. aber wo?

            hmpf

            Kommentar


            • #7
              Skripte ohne pear kommen von genau diesem Server aus an genau diese Datenbank ran? Also praktisch in der selben Datei anderer Code und es funktioniert?

              Kommentar


              • #8
                autsch.. danke wenigstens das hätte ich mal testen können thx.. mom

                Kommentar


                • #9
                  nein das ist es auch nicht.. kann also gar nicht auf denn srver zugreifen

                  PHP-Code:
                  <?php
                  echo "bla 
                  "
                  ;

                  mssql_connect("xxx""xxx""xxx")
                      or die(
                  "Could not connect to database ".mssql_get_last_message());

                  ?>
                  bringt auch wieder einen cgi timeout... uff.. so ein mist.. einer vielleichtz eine idee?

                  Kommentar


                  • #10
                    mssql_connect() baut eine Verbindung zu einem MS SQL Server auf. Das Argument Servername muss ein gültiger Servername sein, der in der 'interfaces'-Datei definiert ist.

                    ??

                    mal danach geschaut

                    Kommentar


                    • #11
                      ps: ip + name + pass so zu posten ist .... nunja

                      http://www.swbulletin.de/p1.gif


                      http://www.swbulletin.de/p2.gif


                      http://www.swbulletin.de/p3.gif

                      (hihihi)

                      Kommentar


                      • #12
                        'interfaces'-Datei ??? - sagt mir ja gar nichts

                        wo finde ich die?

                        Kommentar


                        • #13
                          habs gemerkt

                          Kommentar

                          Lädt...
                          X