Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] [erledigt] imap_open terminiert Skript ¿

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] [erledigt] imap_open terminiert Skript ¿

    Hallo,

    Ich hab ein Problem mit der Funktion imap_open hier mein Skript :

    PHP-Code:
    <?php

    echo    "
    öffne...."
    ;

    $mbox    imap_open(MailserverVerzeichnisKontonameKennwort);

    echo    
    "
    geöffnet"
    ;

    ?>
    Wenn ich mit dem IE das Skript aufrufe bekomm ich "Die Seite kann nicht angezeigt werden."
    Ich denk mal das heißt 404.

    Achja, wenn ich den imap_open Aufruf auskommentiere dann bekomm ich die Ausgabe zu sehen.

    Woran kann das liegen


  • #2
    Hat Keiner ne Idee ¿

    Kommentar


    • #3
      öhm.... ich hoffe mal MailserverVerzeichnis, Kontoname und Kennwort wurden vorher definiert...

      Kommentar


      • #4
        Achja, wenn ich den imap_open Aufruf auskommentiere dann bekomm ich die Ausgabe zu sehen.
        Immer diese wenigen Informationen

        Wo wird eigentlich das Script ausgeführt ?
        Wurden alle Angaben zu imap_open() auch richtig definiert ?

        Woran kann das liegen
        Fragen beantworten, und man wird weiter sehen ...

        Kommentar


        • #5
          Zitat von CIX88
          Achja, wenn ich den imap_open Aufruf auskommentiere dann bekomm ich die Ausgabe zu sehen.
          Immer diese wenigen Informationen

          Wo wird eigentlich das Script ausgeführt ?
          Wurden alle Angaben zu imap_open() auch richtig definiert ?

          Woran kann das liegen
          Fragen beantworten, und man wird weiter sehen ...
          Das Skript wird auf nem PHP Interpreter ausgeführt.

          Die Argumente für imap_open sind richtig.

          Hier die Einstellungen :
          http://wp1003571.wp006.webpack.hosteurope.de/phpinfo
          Hier das Skript :
          http://wp1003571.wp006.webpack.hoste...e/imaptest.php

          Kommentar


          • #6
            versuchs mal hiermit
            PHP-Code:
            <?
             $mbox = @imap_open ("{".$pop3server."/pop3:110}INBOX", "".$username."", "".$passwd.""); 

            if($mbox==""){ 

                
                echo "<font color=red>Verbindung nicht gefunden</font>"; 
               }else{ 
                echo "<font color=red>Verbindung gefunden</font>"; 
             
               }
            ?>

            Kommentar


            • #7
              Zitat von Clan
              versuchs mal hiermit
              PHP-Code:
              <?
               $mbox = @imap_open ("{".$pop3server."/pop3:110}INBOX", "".$username."", "".$passwd.""); 

              if($mbox==""){ 

                  
                  echo "<font color=red>Verbindung nicht gefunden</font>"; 
                 }else{ 
                  echo "<font color=red>Verbindung gefunden</font>"; 
               
                 }
              ?>
              Habs probiert.
              Sieht im Browser genau so aus. ( http://wp1003571.wp006.webpack.hoste.../imaptest1.php )

              Kommentar


              • #8
                Hat sich erledigt, lag an PHP.

                Kommentar


                • #9
                  imap_open problem

                  Zitat von ;248479
                  Hat sich erledigt, lag an PHP.
                  Hallo,

                  ich habe das gleiche Problem. Hab schon Vieles versucht, leider ohne Erfolg. Kannst du mal reinschreiben, wie du es gelöst hast?

                  Herzlichen Dank!

                  Kommentar

                  Lädt...
                  X