Ankündigung

Einklappen
Keine Ankündigung bisher.

Ausgabe von Text klappt nicht

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Ausgabe von Text klappt nicht

    Ich wollte mir für meine HP ein kleines Script coden, das aus zwei txt-Dateien Werte ausliest und diese in einem HTML-Tag an entsprechender Stelle ausgiebt. Das Ergebniss soll ein Ticker sein.

    Mein "Code" sieht so aus:

    Code:
    <?php
    
    #Deffinition der Geschwindigkeitsinhalte
    
     $scroll="speed.txt";
     
    # Wo ist der Text?
    
     $text="text.txt"
     
     #Ausgabe beider Werte
     
     echo "<marquee scrollamount="$scroll">" $text "</marquee>"
    ?>
    Kann mir bitte jemand helfen?

    Danke

    #edit#

    Die Fehlermeldung lautet:

    Code:
    Parse error: parse error, unexpected T_ECHO in ticker/alles.php on line 13
    Das ist die Ausgabezeile, in der der Fehler auftaucht:

    Code:
     echo "<marquee scrollamount="$scroll">" $text "</marquee>"
    ?>
    Admin @ uploadhost.de


  • #2
    echo "<marquee scrollamount="$scroll">" $text "</marquee>"

    Entweder :

    PHP-Code:
    <?php
    ...
    echo 
    "<marquee scrollamount='$scroll'>".$text"</marquee>"

    ?>
    oder

    PHP-Code:
    <?php
    echo "<marquee scrollamount='".$scroll."'>." $text ."</marquee>";
     

    ?>
    ahso ich weiss nun nicht ob du das # als Kommentar Zeichen in PHP nutzt da würde ich doch lieber // oder /* */ nehmen dann.

    Und bei $text = "text.txt"; fehlte das Semikolon noch.

    Kommentar


    • #3
      ahso ich weiss nun nicht ob du das # als Kommentar Zeichen in PHP nutzt da würde ich doch lieber // oder /* */ nehmen dann.
      Das ist egal, # geht wie // oder /* */ ...

      Kommentar


      • #4
        nicht zu vergessen, es fehlt hier:

        $text="text.txt"

        noch das ';'

        Kommentar


        • #5
          und "marquee" wird nicht von allen Browsern interpretiert, da es eine Entwicklung von Microsoft ist.
          auch ein Forum (PHP)

          Kommentar


          • #6
            Geht leider nicht

            habe beide avrianten probiert (mit ";" am Ende der text.txt (ups)), aber es erscheint keine ausgabe...
            Admin @ uploadhost.de

            Kommentar


            • #7
              habe beide avrianten probiert (mit ";" am Ende der text.txt (ups)), aber es erscheint keine ausgabe...
              Benutzt du FF ?

              Kommentar


              • #8
                PHP-Code:
                <?php
                $scroll
                ="4";
                $text="Der bewegte Text";
                echo 
                '<div style="width:50%; border:1px solid black;">';
                echo 
                '<marquee scrollamount="'$scroll'">'htmlentities($text) , '</marquee>';
                echo 
                '</div>';
                ?>
                wird im IE und FF richtig angezeigt.

                Kommentar


                • #9
                  wird im IE und FF richtig angezeigt.
                  Hmmm, im FF ?
                  Wundert mich etwas ...

                  Kommentar


                  • #10
                    Hmmm, im FF ?
                    nein, im FF.

                    grml, probier es doch einfach aus

                    Kommentar


                    • #11
                      grml, probier es doch einfach aus
                      Jo eben deshalb !
                      Bei mir geht das z.B. nicht -> FF 1.0

                      Kommentar


                      • #12
                        Dann machst Du eindeutig was falsch.
                        Ich habe mein Skript wie es da steht mit ie 6.1, mozilla suite 1.7.11 und FF 1.0.6 getestet.
                        Es wird ein schwarzer Rahmen dargestellt und darin bewegt sich der Text von rechts nach links.

                        Kommentar


                        • #13
                          Dann machst Du eindeutig was falsch.
                          Das glaub ich nicht.

                          Kommentar


                          • #14
                            Vielleicht liegts da dran?
                            Nein auch nicht, habs auch gefunden warum.
                            Bei mir ist im FF genrell JS deaktiviert, das schaltet auch das »marquee« mit aus

                            Kommentar


                            • #15
                              Ich schon.

                              Hast Du es bei Dir vielleicht abgeschaltet?
                              http://www.mozilla.org/support/firefox/tips#lay_marquee

                              (Die Möglichkeit wäre da sicher nicht beschrieben, wenn FF <marquee> nicht interpretieren könnte)

                              Kommentar

                              Lädt...
                              X