Ankündigung

Einklappen
Keine Ankündigung bisher.

Web Formulare

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Web Formulare

    Hallo

    Ich habe auf einem Debian Server mit PHP 4.1.2 und apache 1.3.27, diverse Webseiten.

    Nun habe ich diese auf ein Redhat Linux kopiert mit PHP 4.3.2 und apache 2.0.46.


    Jetzt habe ich Probleme mit Parameter übergabe auf Formularen.

    Als Beispiel: test.php

    <?php

    if($test) {
    print "

    Ausgabe: $test</p>";
    }
    else {
    print "

    Dumm gelaufen</p>";
    }

    ?>



    Wenn ich jetzt über den Webbrowser "http://localhost/test.php?test=10" aufrufen, dann erhalte ich die Meldung "Dumm gelaufen"


    Warum???? Ich sollte doch den Wert 10 angezeigt erhalten...

    Auf dem Debain Server funktioniert alles...


    Danke für eure Hilfe

    bigbrother


  • #2
    dann wird aufm redhead server eben alles so eingestellt sein wie es sein soll.

    Code:
    <?php 
    
    if($_REQUEST['test']) { 
    print "
    
    Ausgabe: " . $_REQUEST['test'] . " </p>"; 
    } 
    else { 
    print "
    
    Dumm gelaufen</p>"; 
    } 
    
    ?>
    statt request kann man auch $_GET verwenden aber ich würd an deiner stelle mal im handbuch nachsehen, register_globals und super globals sollte für dich recht intressant sein
    mfg Floh

    Programmers don't die, they GOSUB without RETURN

    Kommentar


    • #3
      Wieso nur?

      Tag auch.

      Das wird daran liegen, dass in der httpd.conf der Tag

      register_variables_global = off (Keine Ahnung, ob mit oder ohne _)

      gesetzt ist. Wenn das der Fall ist schreibe

      register_variables_global = on (Keine Ahnung, ob mit oder ohne _)

      und starte denn Apache neu, dann sollte es gehen...

      MfG
      Yussuf-ff

      Kommentar


      • #4
        Re: Wieso nur?

        Zitat von yussuf-ff
        Tag auch.

        Das wird daran liegen, dass in der httpd.conf der Tag

        register_variables_global = off (Keine Ahnung, ob mit oder ohne _)

        gesetzt ist. Wenn das der Fall ist schreibe

        register_variables_global = on (Keine Ahnung, ob mit oder ohne _)

        und starte denn Apache neu, dann sollte es gehen...

        MfG
        Yussuf-ff
        Der Parameter

        register_variables_global

        existiert in der httpd.conf von apache 2.0 gar nicht...

        bigbrother

        Kommentar

        Lädt...
        X