Ankündigung

Einklappen
Keine Ankündigung bisher.

Veränderung des Include Path wird nicht angenommen

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Veränderung des Include Path wird nicht angenommen

    Hallo,

    ich habe mir das Komplettpaket XAMPP von apachefriends heruntergeladen. Vorher hatte ich das Paket PHPTriad. Nun habe ich alle Einstellungen in der httpd.conf und php.ini soweit vorgenommen, wie diese in dem alten Paket waren. Den Include Path habe ich ebenfalls an eine andere Stelle gelegt als er standardmäßig hinterlegt ist. Doch leider erscheint immer eine Fehlermeldung (Failed opening 'xxx.php' for inclusion (include_path='.;c:\apache\xampp\php\pear\') in C:\xxx\xxx.php on line 41).
    In dieser Fehlermeldung ist ja eindeutig hinterlegt, dass der Include PAth auf den Standardpfad gesetzt ist. Doch warum, wenn in der php.ini etwas anderes steht? Gibt es noch eine Stelle an der er diesen Pfad ziehen könnte?
    Bin dankbar für jede Idee.

    Viele Grüße
    DaIll


  • #2
    Es ist möglich, diesen Wert auch in der httpd.conf zu ändern.

    Evtl. hast du aber auch einfach das falsche *.ini-File bearbeitet. phpinfo() in einer Datei aufgerufen, verrät, welches tatsächlich genutzt ist.

    Kommentar


    • #3
      Du brauchst eigendlich keine Einstellungen in den Dateien vornehmen.

      Wenn der "htdocs" Ordner ein anderer sein soll, braucht du ihn nur in der xampp\apache\conf\httpd.conf die Pfade von DocumentRoot "..." und <Directory "..."> anpassen[/code].

      Gruß,
      Jan

      Kommentar


      • #4
        Du brauchst eigendlich keine Einstellungen in den Dateien vornehmen.

        Wenn der "htdocs" Ordner ein anderer sein soll, braucht du ihn nur in der xampp\apache\conf\httpd.conf die Pfade von DocumentRoot "..." und <Directory "..."> anpassen[/code].
        Das ist mir bekannt. Aber ich möchte mir das absichtlich in ein anderen Pfad legen. Daher muss ich es ändern.

        Es ist möglich, diesen Wert auch in der httpd.conf zu ändern.

        Evtl. hast du aber auch einfach das falsche *.ini-File bearbeitet. phpinfo() in einer Datei aufgerufen, verrät, welches tatsächlich genutzt ist.
        Danke für den Tipp mit der phpinfo. Es gab noch eine andere php.ini im apache Verzeichnis, die er standadmäßig verwendet hat. Jetzt funktioniert alles. Danke!

        Kommentar

        Lädt...
        X