Ankündigung

Einklappen
Keine Ankündigung bisher.

umfrage firefox geht, ie geht nicht

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • umfrage firefox geht, ie geht nicht

    hi ich hab ein kleines problem mit html und zwar hab ich ne umfrage die im firefox funktioniert aber im internet explorer nicht und ich weis nich warum

    also der php code lautet:
    Code:
    <?php
    
      $poll_name = "Wie findet ihr FF 12?";	//Umfragetitel
    
      $poll_answers = array("fantastisch","super","toll","mal schauen","k&ouml;nnte besser sein");
    						  
      $file = "umfrage-1.txt";		//Umfragendatei
    
      echo " 
    <form action='ka.html' method='post'>
      <center>$poll_name</center>
      ";
    
      $i = 0;
      $j = 0;
    
      while(isset($poll_answers[$i])){
        $j=$i+1;
        echo " <input type='radio' name='answer' value='$j'> $poll_answers[$i]
    \n";
        $i++;
      }
    
      $results = file($file,"r");
      if($answer != ""){
        $results[$answer-1] = $results[$answer-1]+1;
        $tmp = fopen($file,"w");
        foreach($results as $save)
          fputs($tmp,chop($save)."\n");
        fclose($tmp);
      }
    
      $total = 0;
      foreach($results as $num)
        $total = $total + $num;
    
      echo "
      <input type='submit' value='Go!'>
      
    
    
      <center>Ergebnisse</center>
      
    
      ";
    
      $i = 0;
      while(isset($results[$i])){
        echo "  $poll_answers[$i]: $results[$i]
    ";
        $i++;
      }
    
      echo "Gesamt: $total.</form>
      ";
    
    ?>
    und nach dem parsen so:
    Code:
    <form action='ka.html' method='post'>
      <center>Wie findet ihr FF 12?</center>
       <input type='radio' name='answer' value='1'> fantastisch
    
     <input type='radio' name='answer' value='2'> super
    
     <input type='radio' name='answer' value='3'> toll
    
    
     <input type='radio' name='answer' value='4'> mal schauen
    
     <input type='radio' name='answer' value='5'> k&ouml;nnte besser sein
    
    
      <input type='submit' value='Go!'>
      
    
    
      <center>Ergebnisse</center>
    
      
    
        fantastisch: 0
    
      super: 1
    
      toll: 0
    
      mal schauen: 0
    
      k&ouml;nnte besser sein: 0
    
    Gesamt: 1.</form>
    wisst ihr wo da das problem ist?

    edit: ups sorry das ich mit mysql forum gepostet habe hab mich wohl etwas verklickt


  • #2
    27.6. Mein Script funktioniert nicht mit Browser XY!
    http://www.dclp-faq.de/q/q-html-validieren.html

    Kommentar


    • #3
      <form action='ka.html' method='post'> <-- stimmt doch

      und alles andere hab ich auch überprüft (glaub ich)

      mfg

      Kommentar


      • #4
        Du musst das Formular doch an eine .php Datei schicken, wenn du es verarbeiten willst. Bei dir steht aber ka.html. Ich denke hier ist der Fehler.
        mfg RudiS

        Kommentar


        • #5
          hmm ne daran lag es nicht

          Kommentar


          • #6
            Hm, was geht denn in Firefox, was im IE nicht geht?
            mfg RudiS

            Kommentar


            • #7
              da bin ich mir jetzt auch nich sicher...

              Kommentar


              • #8
                du weist nicht was nicht geht aber wir sollen das dann wissen?
                Aufstrebend, kompetent und werbefrei.
                www.developers-guide.net

                Kommentar


                • #9
                  ich will doch nur wissen warum meine umfrage mit firefox funktioniert und beim internet explorer nicht

                  mich interessiert ja nicht was nun beim ie geht und was nicht

                  mfg

                  Kommentar


                  • #10
                    Es wäre aber für uns sehr wichtig zu wissen wo das Problem beim IE liegt. Sonst können wir dir nicht helfen.
                    mfg RudiS

                    Kommentar


                    • #11
                      achso das meinst du

                      na ganz einfach da is einfach nix

                      im quelltext steht das form so drin wie oben im code aber im ie sieht man nichts, einfach weiß

                      Kommentar


                      • #12
                        Ersetz doch mal ' durch ".
                        mfg RudiS

                        Kommentar


                        • #13
                          ai so ein mülli mülli

                          wollte die umfrage direkt unter der navigationsleiste machen und hab nicht beachtet das da noch ein <td height="100%"></td> ist *patsch*

                          aber jetzt gehts in beiden browsern

                          thx für eure hilfe

                          Kommentar

                          Lädt...
                          X