Ankündigung

Einklappen
Keine Ankündigung bisher.

blank screen (php&mysql)

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • blank screen (php&mysql)

    Moins,

    kann mir einer sagen warum ich bei folgendem code immer nur nen blank-screen bekomme?
    Code:
    <?php
    error_reporting(E_ALL);
    include("config.php");
    include("mysql.php");
    if (isset($id) {
    $result = mysql_query("SELECT * FROM img WHERE id = ".$id);
    while ($row = mysql_fetch_object($result)) {
    ?> <img border=0 src=./thum/<? echo $row->file; ?>"><? ");
    } else {
    $result = mysql_query("SELECT * FROM img ORDER BY id ASC LIMIT 0 , 10;");
    while ($row = mysql_fetch_object($result)) {
    ?> <img border=0 src=./thum/<? echo $row->file; ?>"> <? ");
    }
    }
    ?>


  • #2
    Re: blank screen (php&amp;mysql)

    Code:
    if ( isset($id) )
    da fehlt bei dir ne klammer ..

    und hier ist jeweils eine zuviel ..
    Code:
    <img border=0 src=./thum/<? echo $row->file; ?>"></a><? ");
    du hast keine fehlermeldung bekommen???
    privater Blog

    Kommentar


    • #3
      Findest du den Code nicht mitunter sehr unübersichtlich?

      Kommentar


      • #4
        nope

        keine fehlermeldung :/


        ja ich weis das mein code unübersichtlich ist - aber soll ja "nur" funktionieren :P danach kann ich dann aufräumen...

        Kommentar


        • #5
          du hast meine korrekturen getestet?
          privater Blog

          Kommentar


          • #6
            ich würde erst einmal zu übersicht... kurze ausgaben mit echo machen und nicht immer ?> und <?php
            Typo3 Suchmaschinenoptimierung <- alles Rund um SEO mit Typo3

            Kommentar


            • #7
              vielleicht hast du (falls du es verwendest) css nicht mit </style> abgeschlossen

              Kommentar


              • #8
                Zitat von shinji
                nope

                keine fehlermeldung :/
                Code:
                error_reporting(E_ALL);
                viel spass beim Fluchen .. .^^

                Kommentar


                • #9
                  ja ich weis das mein code unübersichtlich ist - aber soll ja "nur" funktionieren Razz danach kann ich dann aufräumen...
                  eben ... es funktioiniert aber nicht :P

                  wenn du deinen code übersichtlicher schreiben würdest, kann findet du auch deine fehler selber und schneller

                  Kommentar


                  • #10
                    Zitat von Guradia
                    Zitat von shinji
                    nope

                    keine fehlermeldung :/
                    Code:
                    error_reporting(E_ALL);
                    viel spass beim Fluchen .. .^^
                    schau dir den quelltext an :P

                    ben: jops getestet... bringt au nix ~_~

                    Kommentar


                    • #11
                      Code:
                      <?php
                      error_reporting(E_ALL);
                      
                      include("config.php");
                      include("mysql.php");
                      
                      if (isset($id))
                      {
                      	$result = mysql_query("SELECT * FROM img WHERE id = ".$id);
                      	while ($row = mysql_fetch_object($result))
                      	{
                      		echo "[img]./thum/".$row->file."[/img]";
                      	}
                      }
                      else
                      {
                      	$result = mysql_query("SELECT * FROM img ORDER BY id ASC LIMIT 0 , 10;");
                      	while ($row = mysql_fetch_object($result))
                      	{
                      		echo "[img]./thum/".$row->file."[/img]";
                      	}
                      }
                      ?>
                      also mein debugger zeigt mir keine fehler mehr an ... ansonsten stimmt was mit deiner db nicht!

                      Kommentar


                      • #12
                        ja freak .. wo ist die neuerung?
                        ich sehe heute seit 9:00 hochkommata und anführungszeichen .. .. ich seh einfach net, was du verändert hast ... (außer das du nur noch einen PHP-abschnitt hast) .
                        privater Blog

                        Kommentar


                        • #13
                          ich hab deine korrekturen genommen und ihm alles nochmal aufgeschrieben ... sauber ... wenn das jetzt nicht funzt, dann liegt das an seiner db!

                          Kommentar


                          • #14
                            also hab ich doch richtig gelesen .. *gg*
                            privater Blog

                            Kommentar


                            • #15
                              Hi,

                              mmmh o_o nu funtschtsch >_>

                              danke leut
                              auf euch kann man sich halt doch verlassen XD

                              Kommentar

                              Lädt...
                              X