Ankündigung

Einklappen
Keine Ankündigung bisher.

Eine Menü-Funktion

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Eine Menü-Funktion

    Hallo, habe eine Menü-Funktion, die auf meinem lokalen Apache funktioniert, dennnoch nicht auf meinem Webserver.

    Code:
    <?php
    function icons_get(){
    
    
             $icons_sql = "select * from z_icons_admin order by 'ia_id';";
    
             $icons_id = mysql_query($icons_sql);
             $i = 0;
             while($icon_get = mysql_fetch_array($icons_id)){
    
    
                           $i++;
                           print("<td class='button' valign='top'>");
    
    //Das hier wird nicht so dargestellt, wie es sollte!!!!
    
    print("<a href='".$icon_get[cms_loc_open]."?"
    .session_name()."=".session_id()."&".$icon_get[ia_flag]."'>
    <div class='img'>[img]".$icon_get[ia_loc].$icon_get[ia_name]."[/img]</div></a>");
    
    //Ende CMS_Menü Links.
    
                           print("<div class='ia_desc'>".$icon_get[ia_desc]."</div>");
                           print("</td>");
                           if($i == 4){
                                   print("</tr><tr>");
                           }
              }
    }
    Ganz einfach.
    Ich bekomme nur das Symbol für : Bilder nicht erhalten.
    (Dieser weiße Zettel mit dem roten X in der Mitte.)
    Und verlinked sind die Icons auch nicht.
    Bitte schaut mal im Script! Was könnte der fehler sein?
    Ich habe die Stelle schon angestrichen.

    Dann wieder das Problem wie aus einem letzten Thread.
    Wenn ich den Namen SID verwende, dann taucht der unten in der Adresszeilenvorschau nicht auf. Aber wenn ich es so mache wie oben, dann schon. Ich habe aber Angst, das die Session_id nochmal dazugeschrieben wird.

    was kann ich also tun?
    Ich leg mich zuerst mal hin, bis dann
    php123


  • #2
    *seufz* wie oft hab ich das schon geschrieben :wink:

    ich denke mal die lösung liegt ganz einfach in deinem nicht sauberen code, zum beispiel:

    $icon_get[ia_flag] du verwendest hier keinen string als index sondern den wert der in der konstanten ia_flag gespeichert sein sollte, da diese konstannte aber nicht existiert wird auch kein wert als index eingesetzt und somit wird auch keine variable in deinen print-befehl ausgegeben

    verwendet man das allerdings so:
    $icon_get['ia_flag'] oder $icon_get["ia_flag"] funktionierts.

    warums so ist, dein webserver hat scheinbar die bessere konfiguration als dein lokaler server. denn der webserver interpretiert richtig, dein lokaler server interpretiert etwas lasch.

    im übrigen obiges gilt für alle variablen im printbefehl.
    mfg Floh

    Programmers don't die, they GOSUB without RETURN

    Kommentar


    • #3
      Leider nicht.

      Ich muss sagen, das funktioniert nicht.
      Hat jemand noch eine Idee, warum der Link nicht funktioniert, oder die Bilder nicht angezeigt werden, obwohl die img-src simmt, wenn ich in Eichgenschaften schaue.

      Ach ja, dass sind keine Konstanten, es sind DB-Namen!

      ?
      php123

      Kommentar


      • #4
        wohl eher spaltennamen und durchs auslesen werden sie zu indizes... und anführungszeichen (ob einfache oder doppelte) gehören hin
        mfg Floh

        Programmers don't die, they GOSUB without RETURN

        Kommentar


        • #5
          Ähm, nochmal nein, es geht nicht! Ich muss Dich da enttäuschen.
          Aber danke für Deine Hilfe.

          Ich bekomme zwar die URL in der unteren Adressleiste angezeigt, aber der Link funktioniert nicht. Den Namen für die Action, die zum Bild gehört, wird schließlich auch ausgegeben.

          php123

          Kommentar

          Lädt...
          X