Ankündigung

Einklappen
Keine Ankündigung bisher.

probleme mit php 4.3.6

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • probleme mit php 4.3.6

    hi, ich hab n problem mit php (denk zumindest das es daran liegt...)

    und zwar birngt er direkt nach dem aufruf der site 2 zeilen unten drunter...das is ziehmlich blöd...trat aber erst nach der installation von php 4.3.6 auf. vorher stand das nich da.

    und zwar schreibt er:
    Notice: Undefined index: login in C:\PHPLearn WAMP\Apache2\htdocs\php\login_form.php on line 31

    Notice: Undefined index: pass in C:\PHPLearn WAMP\Apache2\htdocs\php\login_form.php on line 32

    so, in line 31, bzw. 32 steht:

    31 $login=$_POST['login'];
    32 $passw=$_POST['pass'];

    wie gesagt, befor ich php 4.3.6 installiert hatte kam diese meldung nicht!
    jetz ist die frage wie ich des wieder weg bekomme??


  • #2
    Re: probleme mit php 4.3.6

    Zitat von Frossty
    31 $login=$_POST['login'];
    32 $passw=$_POST['pass'];
    Variante *doof*: Du nimmst E_NOTICE aus dem error_reporting raus.

    Variante *gut*:

    Code:
    if (isset($_POST['login']) {
        $login = $_POST['login'];
    } else {
        $login = null;
    }
    Dasselbe für 'pass'.

    Kommentar


    • #3
      super, ich habs mit variante "gut" gemacht...

      vielen dank für die schnell hilfe...danke

      Kommentar


      • #4
        Re: probleme mit php 4.3.6

        Zusätzlich zu dem, was Guradia schrieb:
        Zitat von Frossty
        trat aber erst nach der installation von php 4.3.6 auf. vorher stand das nich da.
        "... aber gestern gings noch..."

        Da die Bedeutung der einzelnen PHP-Konfigurationsoptionen zu den Grundkenntnissen eines Profis gehört, verschiebe ich das Thema ins Anfänger Forum.

        Kommentar


        • #5
          wer benutzt den 4.3.6 :P

          ne aber if(isset()) etc ist besser und auch schon früher dabei, denke ich / hoffe ich

          Kommentar


          • #6
            Zitat von ztk
            wer benutzt den 4.3.6 :P
            warum? was gibts an der version auszusetzen?

            Kommentar


            • #7
              es werden nicht ohne Grund updates rausgebracht

              fixed over 30 bugs
              http://www.php.net/ChangeLog-4.php#4.3.7

              u.a.

              Upgraded bundled GD library to 2.0.23.
              Fixed problems with *printf() functions and '%f' formatting.
              Fixed logic bug in session_register() which allowed registering _SESSION and/or HTTP_SESSION_VARS.
              (wordwrap() wraps lines 1 character too soon).

              Kommentar


              • #8
                Und warum nun .. ist eine gefixte PHP-Version ... schlechter ... als eine mit Fehlern?

                Kommentar


                • #9
                  ? egal, ich bin der Überzeugung, 4.3.7 ist besser als 4.3.6 aber das führt zu einer völlig anderen Diskussion...

                  Kommentar


                  • #10
                    *dotz* (Geräusch eines Schädels Tisch) ...
                    Kommt davon, wenn man die 7 im Link nicht realisiert ... ^^

                    Kommentar

                    Lädt...
                    X