Ankündigung

Einklappen
Keine Ankündigung bisher.

Vermutlicher Konflikt zwischen Version 4.3.1 und 4.3.4?

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Vermutlicher Konflikt zwischen Version 4.3.1 und 4.3.4?

    Zuerst mal ein großes Hallo an alle Forenuser hier!

    Bin ziemlicher Newbie, was PHP betrifft und hoffe, hier Hilfe zu meinem Problem zu bekommen. Zum Hintergrund: Ich versuche gerade, meine ersten Schritte mit einem Beitrag aus der aktuellen C'T (11/2004, Seite 216 ff, falls die wer zur Hand hat) zu machen und das Template-Modul "php-templates" einzubinden. Hab mir dazu den Source "php_templates-1.7.2.tar.gz" runtergesaugt und nach auspacken des Tarballs folgendermaßen installiert:

    phpize
    ./configure --enable-templates=shared
    make
    und dann als root "make install"

    Beim "make install" wurde das Template dann nach /usr/local/lib/php/extensions/no-debug-non-zts-20020429 installiert, laut /etc/php.ini gehören die Templates jedoch nach /usr/share/extensions/no-debug-non-zts-20020429. Nun gut, hab ich's halt vom einen ins andere Verzeichnis kopiert - mich persönlich stört's ja nicht, wenn das Template auf der Platte doppelt vorhanden ist Trotzdem zeigt mir ein "php -m" das Template nicht an.

    Nun kommt der Punkt, bei dem ich vermute, dass er das Problem ist: Ich verwende SuSE 8.2, wo original PHP in Version 4.3.1 vorhanden ist. Vermutlich durch ein SuSE-Update habe ich jedoch auf Version 4.3.4 upgedatet - zumindest bringt mir ein "php -v" die Version 4.3.4 zutage.

    Wenn ich nun ein "which php" absetze, bringt es mir /usr/local/bin/php in Version 4.3.4 hervor. Zusätzlich habe ich in /usr/bin/ PHP in Version 4.3.1 gefunden. Dadurch war mein nächster Versuch, PHP von /usr/local/bin durch einen Symlink auf /usr/bin auf die alte Version überreden zu versuchen. Ein neuerliches "php -v" bringt mir zwar nun die alte Version 4.3.1 zutage und ein "php -m" bringt mir über'n Daumen 3x so viele Module, aber das gewünschte Template war immer noch nicht dabei...

    Hab schon nach einer zweiten php.ini gesucht, die hier evtl nach dem SuSE-Update querschießen könnte, doch ich hab' nur die eine unter /etc.

    Nun meine Frage: Gibts eine Möglichkeit, um eine der beiden Versionen total zu löschen, damit sich die beiden nicht in die Quere kommen? Ich hatte nämlich gestern mal kurz ein Erfolgserlebniss und das Template war da, doch nach einem Neustart war es wieder Geschichte und es war für mich nicht reproduzierbar, wie ich das Template zuvor geladen hatte. Ich weiß nur 100%ig, dass hier die "alte" Version 4.3.1 gegriffen hat und nach dem Reboot wieder 4.3.4 am werkeln war. Wäre also evtl die feinere Lösung, das SuSE-Update rückgängig machen zu können!?


    Für's erste mal danke für die Hilfe und die Tips, und liebe Grüße aus Graz,

    Sascha


  • #2
    Re: Vermutlicher Konflikt zwischen Version 4.3.1 und 4.3.4?

    Zitat von sascha.graz
    Bin ziemlicher Newbie, was PHP betrifft und hoffe, hier Hilfe zu meinem Problem zu bekommen. Zum Hintergrund: Ich versuche gerade, meine ersten Schritte mit einem Beitrag aus der aktuellen C'T (11/2004, Seite 216 ff, falls die wer zur Hand hat) zu machen und das Template-Modul "php-templates" einzubinden. Hab mir dazu den Source "php_templates-1.7.2.tar.gz" runtergesaugt und nach auspacken des Tarballs folgendermaßen installiert:

    phpize
    ./configure --enable-templates=shared
    make
    und dann als root "make install"

    Beim "make install" wurde das Template dann nach /usr/local/lib/php/extensions/no-debug-non-zts-20020429 installiert, laut /etc/php.ini gehören die Templates jedoch nach /usr/share/extensions/no-debug-non-zts-20020429.

    Nun gut, hab ich's halt vom einen ins andere Verzeichnis kopiert - mich persönlich stört's ja nicht, wenn das Template auf der Platte doppelt vorhanden ist Trotzdem zeigt mir ein "php -m" das Template nicht an.
    Woran das wohl liegen mag? <ggg>

    Kommentar

    Lädt...
    X