Ankündigung

Einklappen
Keine Ankündigung bisher.

Insllation PHP 7.4 / Linux Mint 20

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Insllation PHP 7.4 / Linux Mint 20

    Hi,

    (m)eine absolute Einsteigerfrage:

    hatte auf meinem Linux Mint 20 - Rechner ein funktionfähiges PHP 7.3 laufen.

    Die Ausgabe von phpinfo.php im Browseraufruf hatte funktioniert:


    <?php phpinfo(); ?>


    Jetzt upgedatet auf PHP 7.4:

    root@t540p:/var/www/html# php -v
    PHP 7.4.23 (cli) (built: Aug 26 2021 15:51:37) ( NTS )


    ... sieht soweit gut aus, aber die Ausgabe vom obigen phpinfo.php liefert leider nur noch einen leeren Screen.

    Ein einfaches "Hello World" hingegen funktioniert.


    <?php
    echo "Hallo Welt";
    ?>

    Woran kann das liegen?

    Die Ausgabe direkt auf der Shell ("php -f phpinfo.php") funktioniert auch einwandfrei.


    Danke & Gruß
    Tom





    EDIT: installierte PHP-Pakete


    php7.4-cli/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [Installiert,automatisch]
    php7.4-common/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [Installiert,automatisch]
    php7.4-curl/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installiert]
    php7.4-dba/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installiert]
    php7.4-json/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [Installiert,automatisch]
    php7.4-mysql/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [installiert]
    php7.4-opcache/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [Installiert,automatisch]
    php7.4-readline/focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 amd64 [Installiert,automatisch]
    php7.4/focal,focal,now 7.4.23-1+ubuntu20.04.1+deb.sury.org+1 all [installiert]





  • #2
    ... sieht soweit gut aus, aber die Ausgabe vom obigen phpinfo.php liefert leider nur noch einen leeren Screen.
    schau in error log,
    und :
    mod_php php_fpm oder was du hast, unter apache - hat einen eignen ini file .

    Kommentar


    • #3
      Zitat von tomBuilder Beitrag anzeigen
      schau in error log,
      und :
      mod_php php_fpm oder was du hast, unter apache - hat einen eignen ini file .
      var/log/apache2/error.log ... hat keine relevanten Einträge

      Inifile: /etc/php/7.4/apache2/php.ini ... nur was kann falsch konfiguriert sein?


      Folgende Module sind geladen:

      root@t540p:/var/log/apache2# php -m
      [PHP Modules]
      calendar
      Core
      ctype
      curl
      date
      dba
      exif
      FFI
      fileinfo
      filter
      ftp
      gettext
      hash
      iconv
      json
      libxml
      mysqli
      mysqlnd
      openssl
      pcntl
      pcre
      PDO
      pdo_mysql
      Phar
      posix
      readline
      Reflection
      session
      shmop
      sockets
      sodium
      SPL
      standard
      sysvmsg
      sysvsem
      sysvshm
      tokenizer
      Zend OPcache
      zlib

      [Zend Modules]
      Zend OPcache



      Kommentar


      • #4
        du zitoerst schon wiederv cli,
        wie wird dein php über den apache angesprochen ?

        lib-apacher-mod-php-7x ?
        /var/log/php_errors.log ?

        Kommentar


        • #5
          Zitat von tsi Beitrag anzeigen
          ... sieht soweit gut aus, aber die Ausgabe vom obigen phpinfo.php liefert leider nur noch einen leeren Screen.

          Ein einfaches "Hello World" hingegen funktioniert.


          <?php
          echo "Hallo Welt";
          ?>

          Woran kann das liegen?
          Das Klingt sehr eigenartig. Geb mal vor und nach dem phpinfo(); etwas aus. Was passiert?

          Kommentar


          • #6
            Problem gelöst, Danke Euch!
            Die Fehlerursache kann ich nicht belegen, aber es war noch Software einer anderen PHP-Version installiert. Nach dem Aufräumen ging es.

            Danke für Euren Input!

            Kommentar

            Lädt...
            X