Ankündigung

Einklappen
Keine Ankündigung bisher.

gekauftes Script und veraltet PHP 5.7 umstellung Anfänger braucht dringend Hilfe

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • gekauftes Script und veraltet PHP 5.7 umstellung Anfänger braucht dringend Hilfe

    Hallo und schön Tag für euch alle,

    Ich muss zu meiner Entschuldigung vorweg schreiben das ich ein absoluter Anfänger auf PHP bin habe bisher nur mit Html mich beschäftigt.

    Zu mein Problem ich habe mir über Ebay zwei Script günstig gekauft und als Leihe keine Ahnung von PHP gedacht ok kann ja kein Problem sein, das auf
    meinen Webspace Server zu laden alle Daten eintragen Datenbank hoch laden und los gehts... grrrrrr Falsch gedacht.. Struktur und Pfade alles ok, Datenbank wird gefunden nach
    umschreiben von TYPE=MyISAM zu ENGINE=MyISAM vorher konnte ich die Datenbanken garnicht hoch laden nur Fehler mit TYPE. Rausgefunden habe ich noch das wohl
    die Scripte Register_Global=on brauchen und benutzen, was ich aber nicht mehr habe und das wohl auch sehr unsicher ist. Da ich leider von den Verkäufern in keinster weisse
    Support oder Hilfe bekomme nach mehrmaligen Anschriben per eMail versuch ich es auch diesem Weg ... Ich weiss wohl es wird nicht leicht aber ich hoffen auf guten Rat Tat und Hilfe
    von EUCH den Profis hier.
    zu mein Server
    -- phpMyAdmin SQL Dump
    -- version 4.6.4
    -- Host: localhost
    -- Server-Version: 5.7.17
    -- PHP-Version: 5.6.33-1+0~20180105151759.9+jessie~1.gbp0deeda

    Ich versuche das ganze Offline zu erledigen mit xampp aber da bekomme ich garnichts zum laufen... benutze xampp 3.2.2 php 7.2.2
    offline Fehlermeldungen Http: 404 oder 403 oder 500 index funkioniert immer weiterleitung geht nichts mehr.
    Online fast das gleiche meisst Fehler http: 500
    Dazu sind viele Fehler in den Scripten in der verarbeitung die nicht gemacht werden .

    Gibts denn kein Tool oder Hilfe das mir sagen oder helfen kann die Scripte um zu Schreiben in PHP 5.7 und höher.

    Lese viel von Migrating ..Dafür gits kein Tool???oder??? oder ein Editor der gleich alles variablen findet und ändert????

    Ich hoffe habe mich nicht zu blöd mit meiner beschreibung angestellt oder überhaupt alles richtig Erklärt, wenn nicht
    bitte um Nachsicht.. zu dem bin ich nicht mehr der Jüngste... grins.

    Im vorraus vielen lieben Dank für eure Geduld und Rat TAT Hilfe.
    MFG
    Akkibiker




  • #2
    Ein Tool gibt es meines Wissens nach nicht dafür.
    Da hast du wohl Geld zum Fenster rausgeworfen, das hängt davon ab, wie der Verkäufer das Script und die Requirements beschrieben hat.

    Um was für Scripte geht es denn?
    Die Deutsche Rechtschreibung ist Freeware! Du darfst sie kostenlos nutzen, allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

    Kommentar


    • #3
      Ohne das Scrpt zu kennen kann man da garnix sagen! Zeig mal Link welche Scripte zu gekauft hast.

      Kommentar


      • #4
        Zu mein Problem ich habe mir über (..) zwei Script günstig gekauft
        da hast ja eine Geld zurück Garantie, ein schlechte Rating kann man bei so etwas auch immer machen.
        Online fast das gleiche meisst Fehler http: 500
        Da steht meist was im Log.
        In den meisten Fällen ist neu schreiben besser, deswegen auch von mir die Frage:

        Um was für Scripte geht es denn?

        Kommentar


        • #5
          Installier dir am besten PHPStorm (ein PHP-Editor) und richte dein Skript darin ein. PHPStorm wird dir schon anzeigen, welche Funktionen deprecated sind, welche schon nicht mehr unterstützt werden,... Da solltest du auch einiges selbst anpassen können.
          Viele Grüße

          Dirk

          Kommentar


          • #6
            Du kannst dich entweder mit diesem Tool durchhangeln oder gehst manuell die Liste durch: http://php.net/manual/en/migration70.incompatible.php

            Kommentar


            • #7
              Zitat von BLU
              Installier dir am besten PHPStorm (ein PHP-Editor) und richte dein Skript darin ein. PHPStorm wird dir schon anzeigen, welche Funktionen deprecated sind, welche schon nicht mehr unterstützt werden,... Da solltest du auch einiges selbst anpassen können.
              ... kommt mir nicht so vor, als könnte Akkibiker das auf diese Weise selbst lösen.

              Und für sowas braucht man sicher auch keine teure IDE wie PHPStorm. Da reicht ein Texteditor und phpstan. Oder wenn es unbedingt eine IDE sein soll, dann netbeans mit php-plugin.
              Standards - Best Practices - AwesomePHP - Guideline für WebApps

              Kommentar


              • #8
                Mann, Mann, Mann, das klingt alles dermaßen Banane...

                PHP 5.7 ? Wusste gar nicht, dass es die Version überhaupt gibt.

                Register Globals On, TYPE=MyISAM ? Die Skripte müssen aus der Zeit der Christenverfolgung stammen?!

                Das mit PHPStorm lass mal lieber. Wenn Du so schon nicht durchblickst verlierst Du bei der komplexen IDE völlig den Faden.

                Jetzt mal was Konstruktives:

                Zeige hier ruhig mal Deine Skripte bzw. sage, welche das sind. Bei den genannten Merkmalen ist es ausgeschlossen, dass es hier einer
                auf das "geistige Gut" abgesehen hat.

                Es ist schon alles gesagt. Nur noch nicht von allen.

                Kommentar


                • #9
                  Hallo ja
                  das Script hat schon einige Jahre auf dem Buckel, doch wage ich es mal TYPE ist es nicht mehr....werde mal sehen wo ich weiter mache.. vielen dank für die vielen Ratsschläge und Hilfen
                  Melde mich schnellst wider.
                  danke

                  Kommentar

                  Lädt...
                  X