Ankündigung

Einklappen
Keine Ankündigung bisher.

phpinfo(); falscher php.ini Pfad?

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • phpinfo(); falscher php.ini Pfad?

    Guten Abend,

    ich bin gerade dabei phalcon auf einem Server zu installieren, welcher Plesk benutzt, u.a. werden damit unterschiedliche Php-Versionen verwaltet.

    Mein wirkliches Problem lässt sich aber schätze ich davon loslösen. Via phpinfo(); wird mir folgender Pfad zur php.ini angezeigt:
    Code:
     
    /opt/plesk/php/7.0/etc/php.ini
    Nun habe ich exakt diese Datei genommen und etwas geändert (precision = 14 zu = 10), und Apache neugestartet.
    Die Änderung taucht leider nicht auf, in der phpinfo steht weiterhin "precision = 14".

    Was mache ich falsch?

    In Plesk ist folgendes eingestellt:
    Code:
    PHP-Unterstützung (PHP-Version 7.014, PHP ausführen als FPM-Anwendung mit Apache bedient)
    In der phpinfo wird mir folgendes angezeigt:
    Code:
     
    $_SERVER['SERVER_SOFTWARE'] Apache
    Ich starte apache neu mit
    Code:
    sudo service apache2 restart
    Das funktioniert ohne Fehlermeldung.

    Ich bin inzwischen eher ratlos, hat hier vielleicht jemand einen heißen Tipp für mich?

    Liebe Grüße
    ChromOxid


  • #2
    Versuche es mal mit https://support.plesk.com/hc/de/articles/213921105
    Die Deutsche Rechtschreibung ist Freeware! Du darfst sie kostenlos nutzen, allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

    Kommentar


    • #3
      Leider nicht erfolgreich. Apache wird richtig gestoppt und wieder neugestartet (grünes "done"), es ändert sich allerdings nicht an meiner Problemsituation.

      Auf dem Server existieren unterschiedliche vhosts, mein Verständnis davon ist leider nur begrenzt, kann das damit irgendwie zusammenhängen?
      Ich werde das Gefühl nicht los, dass ich einfach an der falschen Datei rumdoktor, andererseits stimmt nunmal der angezeigte Pfad mit der von mir geänderten Datei überein...

      Kommentar


      • #4
        Das neuladen der .ini konnte ich inzwischen beheben, ein umstellen der Version von Php7.0.14 auf Php5.5.9 (OS-Vendor) und wieder zurück im Plesk interface hat geholfen. Warum der vollständige Neustart erfolglos blieb weiß ich nicht.
        Die Installation von Phalcon wird auch leider weiterhin nicht erkannt, aber es liegt immerhin nichtmehr daran, dass die entsprechende .ini nicht gelesen wird.

        Kommentar


        • #5
          Der Vollständigkeit halber hier noch mein Beitrag im Phalcon Forum, bezüglich meines Problems:

          https://forum.phalconphp.com/discuss...plesk-php-7014

          Hello community,

          sadly I have some trouble setting up phalcon on a ubuntu server. The server ist managed via Plesk and there are multiple Php-Versions enabled which may cause some trouble?

          I am using php 7.0.14 in cli (php -v), and using "sudo apt-get install php7.0-phalcon" seems to work just fine, no errors or anything.

          When using phpinfo(); the phalcon.ini gets loaded (/opt/plesk/php/7.0/etc/php.d/phalcon.ini), but there does not show up a phalcon section.

          I have tried to use "phpenmod phalcon" which sadly changes nothing.

          I would appreciate any kind of help

          Best Regards, Ludwig

          Kommentar


          • #6
            Ich würd sagen dein Betrag hat eher im Channel "Frameworks" zu suchen, da Phalcon ein auf C++ basierendes Framework für PHP ist.

            Kommentar


            • #7
              Zitat von Abo Beitrag anzeigen
              Ich würd sagen dein Betrag hat eher im Channel "Frameworks" zu suchen, da Phalcon ein auf C++ basierendes Framework für PHP ist.
              Den Beitrag in dem es spezifisch um Phalcon geht habe ich nurnoch der Vollständigkeit halber verlinkt, (die Wege des "Googlers" sind unergründlich), die "Diskussion" dazu wurde im Phalcon Forum weitergeführt und dort dann auch erfolgreich gelöst (siehe link.)

              Kommentar

              Lädt...
              X