Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Zeichen umwandeln

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Zeichen umwandeln

    Hallo, ich habe folgende URL:
    http://example.com/foo=gül`ßdi
    Lese ich die URL aus, um damit zu arbeiten erhalte ich:
    http://example.com/foo=/g%C3%BCl%60%C3%9Fdi
    Wie kann ich also mit der exakt gleichen URL arbeiten bzw. wie kann ich diesen codierten String zurückumwandeln, dass ich aufschluss auf die orginale habe


  • #2
    Doku?! Siehe http://php.net/manual/de/function.urldecode.php
    Die Deutsche Rechtschreibung ist Freeware! Du darfst sie kostenlos nutzen, allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

    Kommentar


    • #3
      Hallo, danke für deine Antwort. Mit urldecode erhalte ich nicht den in der URL befindenden String sondern /gül`ßdi

      Kommentar


      • #4
        Zeige mal deinen Quelcode.
        Die Deutsche Rechtschreibung ist Freeware! Du darfst sie kostenlos nutzen, allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

        Kommentar


        • #5
          Deine Kodierung ist kacke, die URL ist UTF-8 kodiert. Was benutzt du?
          Windows Server gehören NICHT ins Internet!

          Dildo? Dildo!

          Kommentar


          • #6
            Also kacke, also ne.

            Kommentar


            • #7
              Hat sich erledigt, lag an der Codierung. Danke, Benni.

              Kommentar


              • #8
                Ich klinke mich hier einfach ein.
                Wenn ich eine CSV Tabelle aus Access exportiere werden alle Umlaute in der Tabelle richtig angezeigt. Nach dem Import in MySQL (Latin.....) werden alle durch ein ? ersetzt. Alle Abfragen bzw. Formulare funktionieren trotzdem, auch wenn es nicht gerade schön aussieht. Wandle ich die MySQL Tabelle in utf-8 werden die Umlaute in der Tabelle richtig dargestellt, hurra, aber... in den Formularen werden diese durch ein ? in einer Raute ersetzt. Und nun funktionieren die Abfragen nicht mehr. Welchen Zeichensatz muss ich beim Import auswählen?

                Gesendet von meinem GT-I9300 mit Tapatalk

                Kommentar


                • #9
                  Zitat von ST500 Beitrag anzeigen
                  Ich klinke mich hier einfach ein.
                  Highjacking von fremden Threads macht man nicht, mache einen eigenen Thread für dein Problem auf.
                  Die Deutsche Rechtschreibung ist Freeware! Du darfst sie kostenlos nutzen, allerdings ist sie nicht Open Source, d.h. Du darfst sie nicht verändern oder in veränderter Form veröffentlichen.

                  Kommentar


                  • #10
                    Aha, dann mache ich halt den x-ten Thread zum gleichen Thema auf. Es gibt nähmlich Foren, in denen sowas unerwünscht (und in meinen Augen auch sehr sinvoll) ist.

                    Gesendet von meinem GT-I9300 mit Tapatalk

                    Kommentar

                    Lädt...
                    X