Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] xampp läuft, aber PHP nicht ...

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] xampp läuft, aber PHP nicht ...

    Hi Alle,

    entschuldigt bitte, falls ich im falschen Forum bin oder meine Fragen schon geklärt wurden. Ich bitte gegebenenfalls um einen Tipp (welches Forum geeigneter ist) oder einen Link, falls das Problem schon bekannt ist.

    Ich habe jahrelang xampp unter win7 verwendet, problemlos. Nun bin ich auf win8 umgestiegen worden, und es klappt nicht mehr. Ich erhalte keinerlei Fehlermeldungen, in Status steht PHP grün als installiert, in dem Control-Panel läuft PHP, also alles wie früher.

    Wenn ich eine lokale Datei wie üblich unter Angabe von localhost/xxx.yy/ aufrufe, wird die index.php aufgerufen, aller HTML-Code wird ausgeführt, die Seite sieht gut aus, bis auf den Umstand, dass PHP nicht interpretiert wird. Wenn ich auf der Startseite Links auf andere PHP-Seiten anklicke, werden diese auch angezeigt, aber eben ohne alles, was durch PHP in diesen Seiten gemacht wird.

    Hat irgendjemand eine Idee?


  • #2
    PHP-Code:
    phpinfo(); 
    - Laravel

    Kommentar


    • #3
      Danke für den Tipp. Ich erhalte dann die bekannte lange Liste mit Angaben zu PHP.

      Das bedeutet, dass in diesem Fall der PHP-Code interpretiert wird.

      Warum ist das dann bei den anderen Dateien nicht der Fall?

      [edit]

      gerade ein wenig herumprobiert. Wenn ich

      <?php
      phpinfo();
      ?>

      eingebe, klappt es. Ich habe aber bisher immer

      <?
      phpinfo()
      ?>

      getaggt. Die so geschriebenen Dateien haben jahrelang funktioniert und tun das auch, wenn ich sie vom Webserver aus teste. Lokal mit xampp ging das bisher (unter win 7) immer, aber nun geht das nicht mehr.

      Kann man irgendwo einstellen, dass in anstelle von

      <?php
      ?>

      nur

      <?
      ?>

      schreiben kann, oder muss ich nun alle Dateien fixen?

      Kommentar


      • #4
        http://php.net/manual/de/ini.core.ph...short-open-tag
        Über 90% aller Gewaltverbrechen passieren innerhalb von 24 Stunden nach dem Konsum von Brot.

        Kommentar


        • #5
          Vielen lieben Dank, genau das war's: die Option war auf Off.

          Die Umlaute werden ebenfalls nicht angezeigt. Kann mir jemand bitte sagen, was ich hier verändern muss?

          Kommentar


          • #6
            Zitat von El Schwalmo Beitrag anzeigen
            Die Umlaute werden ebenfalls nicht angezeigt. Kann mir jemand bitte sagen, was ich hier verändern muss?
            Nutze konsequent und durchgängig UTF-8: http://phpforum.de/forum/showthread.php?t=217877

            LG
            Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
            PHP.de Wissenssammlung | Kein Support per PN

            Kommentar


            • #7
              Vielen lieben Dank für die Hilfe. Okay, ich habe iso-8859-1 eingestellt, weil ich das auch bisher verwendet habe, mal überlegen, wie ich das in Zukunft treiben werde.

              An alle noch einmal herzlichen Dank für die schnelle Antwort, nun läuft alles wieder so, wie ich es haben möchte. Die Tipps haben mir sehr geholfen.

              Kommentar

              Lädt...
              X