Ankündigung

Einklappen
Keine Ankündigung bisher.

$_SERVER['HTTP_USER_AGENT'] - leerer Bildschirm

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • $_SERVER['HTTP_USER_AGENT'] - leerer Bildschirm

    Hallo,


    bin blutiger PHP-Anfänger und arbeite mich gerade durch ein Tutorial.
    Dort heisst es, dass man mit einem gewissen Skript prüfen kann, ob der vom Besucher benutzte Browser der Internet Explorer ist. Das Skript lautet wie folgt:

    PHP-Code:
    <?php
    if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
        echo 
    "Sie benutzen Microsofts Internet Explorer.<br />";
    }
    ?>
    Bei mir zeigt der Browser nur eine leere Seite an.
    Liegt das vielleicht an irgendwelchen Privacy-Einstellungen im Browser?


    MFG
    Nils


  • #2
    Die Abfrage ist so eigentlich korrekt ich würde es mal mit
    PHP-Code:
    <?php
    phpinfo
    (); 
    ?>
    probieren ob er dort HTTP_USER_AGENT ausgibt oder nicht.

    Kommentar


    • #3
      - welchen Browser benutzt du?
      - wie heist deine Skriptdatei und wie rufst du dein Skript im Browser auf?
      - ein Webserver läuft hoffentlich
      PHP-Klassen auf github

      Kommentar


      • #4
        Zitat von Nils32 Beitrag anzeigen
        Dort heisst es, dass man mit einem gewissen Skript prüfen kann, ob der vom Besucher benutzte Browser der Internet Explorer ist.
        Dann lügt das Script. Man kann anhand von $_SERVER['HTTP_USER_AGENT'] nicht ermitteln welcher Browser verwendet wird (ja, mit einer gewissen Wahrscheinlichkeit, aber keinesfalls zuverlässig) - was hast du wirklich vor?

        Kommentar

        Lädt...
        X