Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Verbindungsaufbau mit MySQL Datenbank über eine extra Datei!

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Verbindungsaufbau mit MySQL Datenbank über eine extra Datei!

    Hallo Leute!

    So habe ich bis jetzt mit meiner Datenbank connectet um Daten dort abzuspeichern:

    PHP-Code:
    mysql_connect("localhost","root","123");
    mysql_select_db("db"); 
    Jetzt, wo sich mein Programm erweitert, merke ich, dass es schlauer ist, die Datenverbindung in einer separaten File abzuspeichern. Diese soll db.inc.php heißen. Sie sieht bei mir so aus:

    PHP-Code:
    <?
    $db = mysqli_connect("localhost", "root", "123", "db");
    if (!$db)
    {
     exit("Verbindungsfehler: ".mysqli_connect_error());
    }
    ?>
    Ersetze ich ersten Code nun mit
    PHP-Code:
    include("db.inc.php"); 
    ersetze, funktioniert der Verbindungsaufbau jedoch nicht.

    Woran liegt es, was hab ich falsch gemacht?

    Freue mich über eure Antworten
    Mit freundlichen Grüßen
    Marcel


  • #2
    - Code bitte in den PHP Code tags posten
    - mysql ist veraltet, hab ich dich schon im anderen Thema drauf hingewiesen (oder?

    moment -> du mischt derzeit beides, das kann nicht funktionieren mysql_ und mysqli_ nicht mischen.


    unktioniert der Verbindungsaufbau jedoch nicht
    Heißt was?
    -> Fehlermeldung?
    -> error_reporting aufgedreht?
    -> debugge: Stimmt der PFad etc.. http://php-de.github.io/jumpto/leitfaden/
    -> mal alles auf mysqli_ ändern

    LG
    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
    PHP.de Wissenssammlung | Kein Support per PN

    Kommentar


    • #3
      Du hast jetzt aber nicht nur die Verbindung in mysqli_ transferiert und den Rest noch in mysql_ gelassen, oder?
      Man beachte übringes, dass sich mysqli_ Funktionen anders verhalten als deren mysql_ Äquivalent.
      Die mysql_* Erweiterung ist veraltet!
      Besser: mysqli_* oder (noch besser) PDO

      Kommentar


      • #4
        Ah, jetzt hab ich's raus! Ich habe jetzt mein ganzes Script, wenn man das so sagen darf, auf "mysqli" geupdated, einige Parameter verändert und jetzt funktioniert alles wunderbar
        @hausl: nein, das muss ein anderer gewesen sein

        Kommentar


        • #5
          @hausl: nein, das muss ein anderer gewesen sein
          Oh sry, nichts für ungut, war gerade zu faul zum Nachsehen und das kommt täglich
          Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
          PHP.de Wissenssammlung | Kein Support per PN

          Kommentar

          Lädt...
          X