Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] mysql / mysqli

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] mysql / mysqli

    Hallo!
    Bald geht der Befehl mysql nicht mehr - so weit bekannt. Ersetzt werden soll er gegen mysqli oder POD (???).
    Jetzt habe ich versucht mit mysqli auf meinem Webspace (bei all-inkl) zu arbeiten und jedes mal bekomm ich eine Fehlermeldung vom Script.

    Kann es sein, das die unteren Versionen mit mysqli nicht arbeiten?
    Ab wann genau arbeitet mysqli?

    evtl kann man sich ja eine Weiche bauen?
    PHP-Code:
    $phpversion phpinfo();
    if(
    $phpversion<X)
    {
    $Operator "mysql";
    }else{
    $Operator "mysqli";
    }

    $Operator_query... 
    Geht so was bzw haltet ihr das für sinnvoll?! (und bitte nicht steinigen!)


  • #2
    Falscher Denkansatz von dir...

    Richtig wäre:

    Jetzt habe ich versucht mit mysqli auf meinem Webspace (bei all-inkl) zu arbeiten und jedes mal bekomm ich eine Fehlermeldung vom Script.
    1. Welche Fehlermeldung?
    2. Fehler verstehen
    3. Beheben
    4. Spaß haben

    Wenn du bei konkreten Fehlern auch nach Eigenrecherche nicht weiterkommst, dann kannst ja hier wiederkommen.

    Hier ist zB ein gutes mysqli-Tut.: http://www.peterkropff.de/site/php/m...grundlagen.htm

    LG
    Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
    PHP.de Wissenssammlung | Kein Support per PN

    Kommentar


    • #3
      Theoretisch nette Idee mit deinem kleinen Script, aber:
      1. Die Funktionen haben nicht immer die gleiche Signatur. Das wird dir schon bei [MAN]mysql_connect[/MAN] vs. [MAN]mysqli_connect[/MAN] auffallen.
      2. Die MySQLi-API gibt es seit PHP 5. PHP4 läuft (so gut) nirgends mehr, zumindest nicht ohne das es noch eine aktuellere Version gibt und/oder es einen sehr schwerwiegenden Grund dafür gibt. Bei all-inkl auf nem Shared Server gibts sicher PHP5.

      Kommentar


      • #4
        Der Code ist wie folgt:

        Dateiname= test.php
        PHP-Code:
        <?
        echo "<br>";
        include ("db.inc");

        $ergebnis = mysqli_query("SELECT UName FROM user");
        while($row = mysqli_fetch_object($ergebnis))
        {
          echo $row->UName;
        }
        ?>
        PHP Version: 5.2.17-nmm2

        Fehlermeldungen:
        Warning: mysqli_query() expects at least 2 parameters, 1 given in ***/test.php on line 7

        Warning: mysqli_fetch_object() expects parameter 1 to be mysqli_result, null given in ***/test.php on line 8
        Führe ich das Script nur mit mysql aus, läuft es ohne Probs

        Kommentar


        • #5
          Warning: mysqli_query() expects at least 2 parameters, 1 given in ***/test.php on line 7
          [MAN]mysqli_query[/MAN]
          Zitat von nikosch
          Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

          Kommentar


          • #6
            Und zur PHP-Version siehe: http://all-inkl.com/wichtig/faq/#faq_software
            Du solltest zumindest eine 5.3er Version verwenden.

            Kommentar


            • #7
              Dh. das ich die Datenbankverbindung nimmer in einer INC-Datei packen kann, sondern als Variable in die mysqli - Anwendung packen muss? Hab ich das richtig verstanden?

              Kommentar


              • #8
                Das heißt, dass die Connection-Variable nicht mehr global verfügbar ist (bzw. intern verwaltet wird, ja).
                --

                „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                --

                Kommentar


                • #9
                  Danke sehr. dann muss ich mich umstellen
                  Hatte bisher die Datenbankconnection per INC - Datei included.

                  Kommentar


                  • #10
                    Mit etwas glück kennt dein Webserver inc nicht und schickt es einfach so raus.
                    Zitat von nikosch
                    Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

                    Kommentar

                    Lädt...
                    X