Ankündigung

Einklappen
Keine Ankündigung bisher.

Uft 8

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Uft 8

    Erstmal Hallo an alle,

    Ich habe immer noch mit russischem Schrift zu Kämpfen.
    Zu meinem Problem:

    Es geht um Login Formular. Ich will den betreiben als in Deutschland so auch in Russland.

    Wenn ich bei mir zu Hause mich da registriere und anmelde, alles kein Problem, Mit englischen Buchstaben gemeint.

    Registrieren und anmelden mit russischen Buchstaben geht bei mir auch aber, wenn ich aus Russland aus mich da einlege , sagt er mir, kein User vorhanden. Dann registriere ich mich da ich, mit den selben nahmen.

    Und was sehe ich in Datenbank, die Username werden unterschiedlich kodiert,

    Wie kann das sein, wie kann ich das ändern.?
    Ich habe Set Name bei Datenbank Verbindung angelegt.
    Trotz dem finde ich nicht den grund


  • #2
    Versuch die Eingaben, die in die Datenbank gehen nach einem Standard zu kodieren

    Kommentar


    • #3
      http://php-de.github.io/jumpto/mysql-and-utf8/
      Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
      PHP.de Wissenssammlung | Kein Support per PN

      Kommentar


      • #4
        Immer wieder das gleiche. Das habe ich alles bei mir. Und kann mich einlogen auf russisch.die Seite ist auch super in russisch dargestellt. Er kodiert nur unterschiedlich die Daten in Datenbank. Z.b. Chrom kodiert auf eigene Weise, Firefox schickt das ganz anders ab.

        Kommentar


        • #5
          Im Browser (mit Meta-Tag, Header, etc.) läuft auch alles mit UTF-8?

          Kommentar


          • #6
            Genau, das habe ich auch

            Kommentar


            • #7
              Die Spalten und Tabellen sind auch in UTF-8?
              GitHub.com - ChrisAndChris - RowMapper und QueryBuilder für MySQL-Datenbanken

              Kommentar


              • #8
                Das auch. Ja

                Kommentar


                • #9
                  Ich habe mir schon gedacht ob das nicht am Server liegt

                  Kommentar


                  • #10
                    Ich rate mal mit:
                    Formulardaten in UTF-8 übergeben ? (ggf. mit accept-charset="utf-8" sichergestellt ?)

                    Irgendwo ein Tippfehler wie in deinem Thread-Titel ?
                    PHP-Klassen auf github

                    Kommentar


                    • #11
                      Die PHP-Script-Dateien selbst auch in/als UTF-8 (ohne BOM) gespeichert?

                      Versuch das ev. sonst auch mal: http://stackoverflow.com/questions/9...active#tab-top
                      Debugging: Finde DEINE Fehler selbst! | Gegen Probleme beim E-Mail-Versand | Sicheres Passwort-Hashing | Includes niemals ohne __DIR__
                      PHP.de Wissenssammlung | Kein Support per PN

                      Kommentar

                      Lädt...
                      X