Ankündigung

Einklappen
Keine Ankündigung bisher.

Datetime Picker für alte Browser

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Datetime Picker für alte Browser

    Hallo,

    bin zur Zeit auf der Suche nach einem Datetime Picker welcher ab der IE Browserversion 4 läuft.
    Dadurch kann ich ja weder auf die jQuery zugreifen noch das input type="datetime" Modell von HTML5 benutzen.

    Habe nun schon ein wenig rumgegoogelt aber nichts gefunden was auf einem Linux Webserver betrieben werden kann.

    Ich kann mir aber auch nicht vorstellen das diese Datetime Picker eine erfindung ist die erst seit 2008 Angeboten wird.

    Hat da wer nen Vorschlag für ein Plugin oder kann mir einen Link senden?

    (Selber Programmieren möchte ich so gut es geht umgehen)


  • #2
    Zitat von Nagazi Beitrag anzeigen
    ... ab der IE Browserversion 4 läuft.


    Sorry, mehr gibts dazu nicht zu sagen. Unterstütze ab Version 9, sonst gibts die anderen Versionen in hundert Jahren noch.

    Kommentar


    • #3
      IE4? Ist das willkürlich oder gibt es dafür ein Grund?

      Kommentar


      • #4
        Er hat sich sicher verschrieben.
        Standards - Best Practices - AwesomePHP - Guideline für WebApps

        Kommentar


        • #5
          IE 4 unterstützt nicht mal CSS2. Viel Erfolg also dann auch beim Layout.

          Kommentar


          • #6
            jquery 1.x benötigt mindestens IE6, jquery 2.0 mindestens IE9

            http://jquery.com/browser-support/

            Als jquery plugin wirst du da also mit absoluter Sicherheit nichts finden, was unter IE 4 funktioniert.
            Über 90% aller Gewaltverbrechen passieren innerhalb von 24 Stunden nach dem Konsum von Brot.

            Kommentar


            • #7
              Welches BS wäre das denn dann? W95? W98? WNT? Firefox2.0 müsste da dann noch laufen. Aber solche alten Systeme wären lächerlich.
              Standards - Best Practices - AwesomePHP - Guideline für WebApps

              Kommentar


              • #8
                Zitat von rkr Beitrag anzeigen
                Welches BS wäre das denn dann? W95? W98? WNT? Firefox2.0 müsste da dann noch laufen. Aber solche alten Systeme wären lächerlich.
                Ja genau um die Systeme handelt es sich
                Jeder Informatiker kennt den Spruch: "Never touch a running system"
                Und genau dieser Fall tritt auch bei meiner Programmierarbeit auf. es sind noch dutzende Rechner dort im Betrieb welcher aufgrund von Software und Funktionalität nicht geupdatet werden können. Wäre auch nebenbei Sinnlos.

                Muss doch trotzdem aus der Zeit eine Art Datetime Picker geben

                FF2.0 würde sich auch noch installieren lassen. Falls es damit einfacher sein würde.

                Kommentar


                • #9
                  Nagazi bitte nenn mir mal das Unternehmen welches diese Betriebsysteme nutzt. Möchte wissen, wo ich definitiv nichts Einkaufen werde.
                  Zitat von nikosch
                  Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

                  Kommentar


                  • #10
                    Zitat von Nagazi Beitrag anzeigen
                    Muss doch trotzdem aus der Zeit eine Art Datetime Picker geben
                    Nein. Und wenn dein Chef das nicht glauben will, mach dir ne gechillte Woche und sag dann nochmal Nein. Irgendwo ist auch mal Schluss mit der "updaten ist kacke" Mentatlität.

                    DatePicker und JavaScript für Frontends wurden erst relativ spät entwickelt. Vorher gabs Java und ActiveX-Applikationen, die im Browser liefen. Damit kannste sowas vielleicht noch nachbauen. Aber ganz im Ernst: Erspar dir den Stress und sorg lieber dafür, dass die System abgelöst werden.
                    Lerne Grundlagen | Schreibe gute Beispiele | PDO > mysqli > mysql | Versuch nicht, das Rad neu zu erfinden | Warum $foo[bar] böse ist | SQL Injections | Hashes sind keine Verschlüsselungen! | Dein E-Mail Regex ist falsch

                    Kommentar


                    • #11
                      Nagazi bitte nenn mir mal das Unternehmen welches diese Betriebsysteme nutzt. Möchte wissen, wo ich definitiv nichts Einkaufen werde.
                      ..google müsste aus Sicherheitsgründen auch gesperrt sein, bei den Sicherheitslücken

                      Jeder Informatiker kennt den Spruch: "Never touch a running system"
                      Jep, aber das trifft definitiv nicht auf ein System zu, was wirklich in dem Fall "uralt" scheint.

                      FF2.0 würde sich auch noch installieren lassen. Falls es damit einfacher sein würde.
                      Ihr verschleppt damit euer eigentliches Problem und eure nicht vorhandenen Sicherheitsbedenken (sorry) nur stetig weiter. Wundert mich ehrlich gesagt, das bisher noch "nichts" passiert ist.

                      mfg wolf29
                      while (!asleep()) sheep++;

                      Unterschätze nie jemanden der einen Schritt zurück geht! Er könnte Anlauf nehmen.

                      Kommentar


                      • #12
                        Naja, ich kenne ein Unternehmen, da ist noch Windows3.11 und WinNT im Einsatz. Für sündhaft teure CNC Maschinen, für deren Software auch nie mehr ein Update erscheinen wird. Die Systeme sind aber seit Jahren virtualisiert.
                        Standards - Best Practices - AwesomePHP - Guideline für WebApps

                        Kommentar


                        • #13
                          Herzlichen Glückwunsch...

                          Aus einem ganz alten Projekt ausgegraben http://www.calendarxp.net/tt_pop.shtml

                          Kommentar


                          • #14
                            Herzlichen Glückwunsch...

                            Aus einem ganz alten Projekt ausgegraben http://www.calendarxp.net/tt_pop.shtml
                            Ich glaube, das ist kontraproduktiv und der Threadersteller wird an der Ausgangssituation nichts ändern...jetzt, da er nen Beispielcode hat!
                            while (!asleep()) sheep++;

                            Unterschätze nie jemanden der einen Schritt zurück geht! Er könnte Anlauf nehmen.

                            Kommentar


                            • #15
                              Ich würde die uralt-PCs virtualisieren und nur noch via Citrix oder VNC für modernere Arbeitsplätzen zur Verfügung stellen. Alles andere hat keinen Sinn mehr.
                              Standards - Best Practices - AwesomePHP - Guideline für WebApps

                              Kommentar

                              Lädt...
                              X