Ankündigung

Einklappen
Keine Ankündigung bisher.

Problem mit verlinkung

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Problem mit verlinkung

    hey wenn ich in einer verlinkung (<a href="link">blabla2</a>) den link etwas länger mach funktioniert mein a:hover nicht mehr...

    Codeausschnitt:

    Code:
    <a href="index.php?page=impress">Impressum</a>
    Würde ich statt "index.php?page=impress" "impress" einfügen würde der hover funktionieren!


    hat jemand eine ahnung wieso?


  • #2
    Weder die „Problembeschreibung“ noch der Minimalcode haben irgendeine Aussagekraft.

    Stelle bitte ein Online-Beispiel bereit (valides HTML & CSS), und beschreibe genau, welches Verhalten du wo erwartest und wie die Anzeige in welchem Browser davon abweicht.

    Kommentar


    • #3
      Also:

      Ok hier die Scriptausschnitte!

      Link zur Seite

      Kommentar


      • #4
        Und nun? hover funktioniert doch wunderbar.
        @fschmengler - @fschmengler - @schmengler
        PHP Blog - Magento Entwicklung - CSS Ribbon Generator

        Kommentar


        • #5
          Was sagt Firebug dazu?

          [edit]
          Und nun? hover funktioniert doch wunderbar.
          Dito. Hast du mal [F5] gedrückt?
          http://hallophp.de

          Kommentar


          • #6
            oh habe bemerkt es geht zwar in Firefox doch nicht in Opera.

            Wie geht man nun bei so einem problem vor?

            Kommentar


            • #7
              Bei mir funktionieren alle hover, sowohl die auf den Grafiken als auch die auf den Textlinks.

              Firefox 3.6.8
              Chrome 5.0.375.125
              PHP-Code:
              if ($var != 0) {
                
              $var 0;

              Kommentar


              • #8
                Bei mir geht es auch im Opera. Auch da kann man [F5] drücken.
                http://hallophp.de

                Kommentar


                • #9
                  Ich kann auch kein Problem mit dem Hover-Effekt feststellen.

                  Dein Code solltest du trotzdem validieren, denn der enthält noch einige Fehler:
                  [Invalid] Markup Validation of http://gisdesigns.bplaced.net/ - W3C Markup Validator

                  Kommentar


                  • #10
                    In Opera gehen sie zwar in der navi (rechts oben) aber nicht im Footer

                    Liegt das an mir oder ist doch was falsch?

                    Kommentar


                    • #11
                      @Opera -> Strg + F5 falls der mal ( wieder ) css-code verschluckt
                      [URL="https://gitter.im/php-de/chat?utm_source=share-link&utm_medium=link&utm_campaign=share-link"]PHP.de Gitter.im Chat[/URL] - [URL="https://raindrop.io/user/32178"]Meine öffentlichen Bookmarks[/URL] ← Ich habe dir geholfen ? [B][URL="https://www.amazon.de/gp/wishlist/348FHGUZWTNL0"]Beschenk mich[/URL][/B].

                      Kommentar

                      Lädt...
                      X