Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Komischer Strich

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Komischer Strich

    Hallo Zusammen,

    ich habe eine ganz normale Tabelle mit einem Bild als Link. Auf der Seite ist auch ein Formular, mit Benutzeranmeldung. Wenn keine eingabe gemacht wird, soll text auf der seite angezeigt werden, das Funktioniert ohne Probleme, doch dann erscheint in dem Bild ein komischer Strich, wo kommt der her

    PHP-Code:
    <table border ="3" cellspacing="0" cellpadding="0" width="100%" height="100%">
     <tr height="70%">
      <td align="center" valign="middle">
        <table border="1" cellspacing="0" cellpadding="2">
        <tr>
             <td align="left" valign="middle" width="100">
          <a href="http://www.squid-cache.org" target="new" title="Squid Website"><img src="./bilder/squid-logo.png" border="0" width="100%" alt="squid-logo.org"></a>
         </td>
         <td align="center" valign="middle"><font size="6">Anmeldung</font></td>
        </tr>
          <tr>
          <td align="center" valign="top" colspan="2"><hr width="320"></td>
          </tr>
         <tr>
       <td align="left" valign="middle">Benutzer:</td>
       <td align="right" valign="middle"><input type="text" name="benutzer" size="20" maxlength="20" autocomplete="off"></td>
        </tr>
        <tr>
       <td align="left" valign="middle">Kennwort:</td>
       <td align="right" valign="middle"><input type="password" name="kennwort" size="20" maxlength="20" autocomplete="off"></td>
      </tr>
      <tr>
      <td align="center" valign="top" colspan="2"><hr width="320"></td>
      </tr>
      <tr>
      <td align="center" valign="middle" colspan="2"><input type="submit" name="senden" value="Anmelden"></td>
      </tr>
      <tr>
      <td align="left" valign="middle" colspan="2"><? echo $eingabe; ?></td>
      </tr>
    </table>
    </td>
    </tr>
    <tr>
    <td align="left" valign="bottom"><? echo $text; ?></td>
    </tr>
    </table>
    Sieht so aus.

    Doch wenn dann die Fehlermeldung kommt, sieht es so aus und es taucht ei nstrich auf

    bild mit strich

    Gruß Alecane


  • #2
    Hallo

    Gibt es dazu irgendwelche CSS-Styleangaben? In welchem Browser taucht das Problem auf? Wie lautet der restliche HTML-Code der Seite, der evtl zum Bug oder zur Falschanzeige führt? ...

    Gruß, php2go

    Kommentar


    • #3
      Meinst du den String unter der Tabelle oder den zwischen Button und Tabelle? Könne auch nen Tabellen Fehler sein wenn man z.B. einmal <td> oder so vergisst.


      Kommentar


      • #4
        Servus,

        Zitat von BattleMaster246 Beitrag anzeigen
        Meinst du den String unter der Tabelle oder den zwischen Button und Tabelle? Könne auch nen Tabellen Fehler sein wenn man z.B. einmal <td> oder so vergisst.
        ich meinte kein string, sonder strich

        unter dem bild (squid logo) wird ein strich aufgeführt (ich habe es leicht rosa gemacht), aber nur wenn in der einen spalte der text angezeigt wird.

        CSS ist ein wenig enthalten, aber auch wenn ic hes raus nehme ändert sich nix.
        Ich benutze den Browser Firefox 3.5.8 hier der komplette code:

        PHP-Code:
        <?
        session_start();

        include "./funktionen.php";
        $text=NAME("text");

        if(isset($_SESSION['text']))
        {
            $eingabe="Falsche Benutzerkennung eingegeben";
            unset($_SESSION['text']);
        }
        ?>

        <html>

        <head>
        <title>Anmeldung</title>
        <style type="text/css">
        a:focus{ outline:none; }
        body{ font-family:Helvetica; }
        </style>
        </head>

        <body>

        <form method="post" action="pruefung.php">

        <table border ="3" cellspacing="0" cellpadding="0" width="100%" height="100%">
            <tr height="70%">
                <td align="center" valign="middle">
                    <table border="1" cellspacing="0" cellpadding="2">
                        <tr>
                            <td align="left" valign="middle" width="100">
                                <a href="http://www.squid-cache.org" target="new" title="Squid Website"><img src="./bilder/squid-logo.png" border="0" width="100%" alt="squid-logo.org"></a>
                            </td>
                            <td align="center" valign="middle"><font size="6">Anmeldung</font></td>
                        </tr>
                        <tr>
                            <td align="center" valign="top" colspan="2"><hr width="320"></td>
                        </tr>
                        <tr>
                            <td align="left" valign="middle">Benutzer:</td>
                            <td align="right" valign="middle"><input type="text" name="benutzer" size="20" maxlength="20" autocomplete="off"></td>
                        </tr>
                        <tr>
                            <td align="left" valign="middle">Kennwort:</td>
                            <td align="right" valign="middle"><input type="password" name="kennwort" size="20" maxlength="20" autocomplete="off"></td>
                        </tr>
                        <tr>
                            <td align="center" valign="top" colspan="2"><hr width="320"></td>
                        </tr>
                        <tr>
                            <td align="center" valign="middle" colspan="2"><input type="submit" name="senden" value="Anmelden"></td>
                        </tr>
                        <tr>
                            <td align="left" valign="middle" colspan="2"><? echo $eingabe; ?></td>
                        </tr>
                    </table>
                </td>
            </tr>
            <tr>
                <td align="left" valign="bottom"><? echo $text; ?></td>
            </tr>
        </table>
            
        </form>

        </body>
        </html>

        Kommentar


        • #5
          Alos ich habe das Bild estwas kleiner gemacht mit width="60%", wenn ich diesen tag komplett wegnehme, dann ist das problem mit dem strich gelöst. komisch

          Kommentar


          • #6
            du solltest die höhen- und breitenangaben unbedingt per css machen und nicht als attribut verwenden...

            Kommentar


            • #7
              Zitat von Baltasar Beitrag anzeigen
              du solltest die höhen- und breitenangaben unbedingt per css machen und nicht als attribut verwenden...
              Ja denke das werde ich mir so bei behalten

              Kommentar


              • #8
                Bilder in Links zeigen eigentlich immer einen Unterstrich. Wo wird der denn bei Dir entfernt? Ich tippe mal auf einen Cache-Effekt.
                --

                „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                --

                Kommentar


                • #9
                  Zitat von nikosch Beitrag anzeigen
                  Bilder in Links zeigen eigentlich immer einen Unterstrich. Wo wird der denn bei Dir entfernt? Ich tippe mal auf einen Cache-Effekt.
                  Das wusste ich gar nicht, also ich entferne den rahmen von links im css code. und der rahmen den Bildes wird auf 0 gesetzt, gibt es etwa noch einen anderen befehl um den strich unter bilderlinks zu entfernen?

                  Kommentar


                  • #10
                    Stimmt, ich habe Quatsch erzählt. Verlinkte Bilder erhalten eine Rahmen...
                    --

                    „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                    Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                    --

                    Kommentar

                    Lädt...
                    X