Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Mozilla / Internet Explorer

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Mozilla / Internet Explorer

    ich hab ne Seite mit mehreren Tabellen gebaut. Und nu habbich die in Mozilla (normal und Firefox) anschauen wollen, und es sieht bissl arg daneben aus!
    Allerdings im Internet Explorer wird alles so dargestellt wie ich es will. Und in meinem HTML-Editor auch (Phase 5).

    Kann mir jemand sagen warum das bei Mozilla so "falsch" aussieht und beim IE nicht, und am besten noch wie ich den Mozilla dazu bringe das richtig anzuzeigen!

    Hier der Link: http://www.i-wars.net/test7/

    Lasst euch nciht stören von eventuellen Fehlern....


  • #2
    Da hilft am besten der W3C Validator.
    Wenn alles valid ist und noch nicht geht, kannst du nochmal fragen

    Kommentar


    • #3
      http://validator.w3.org/check?uri=ht...tomatically%29

      Kommentar


      • #4
        Ähmjo... das habbich nu inzwischen au gesehen... aber manchmal versteh ich garnich was da falsch sein soll!

        Außerdem besteht die Seite ja aus 4 PHP-Dateien.. dadurch stimmen die Linien angaben ja garnimmer!
        Komischerweise werden die einzelnen PHP-Seiten einzeln korrekt angezeigt: http://i-wars.net/test7/right2.php
        Nur wenn ich sie zusammensetze stimmts nimmer!

        Kommentar


        • #5
          Wow, 324 Fehler, nicht schlecht

          Kommentar


          • #6
            Zitat von Juuro
            Ähmjo... das habbich nu inzwischen au gesehen... aber manchmal versteh ich garnich was da falsch sein soll!
            Welchen Fehler verstehst du nicht?
            So kompliziert sind die Fehlermeldungen des Validator doch auch wieder nicht. Nun ja, zwar auf englisch, aber das wirst wohl noch hinbekommen.

            Nun mach erst mal so triviale Fehler raus wie die vergessenen "alt" Tags.

            Und noch was: ist dein DocType richtig? Muss das XHTML-Standard sein?

            Kommentar


            • #7
              Also erstmal kann ich dir den SelfHTML Validator empfehlen! Der hat für dich wohl hilfreichere Fehlermeldungen:
              http://validator.de.selfhtml.org/

              Dann soltest du umbedigt über den Dokumenttyp nachdenken, um validen HTML-Code zu bekommen. Was du schreibst ist auf alle Fälle kein XHTML und schon garnicht "strict". Am Besten liest du dir mal diese Quelle durch: http://de.selfhtml.org/html/allgemei...tm#dokumenttyp

              Als schnelle Hilfe ändere die ersten zwei Zeilen von
              Code:
              <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
                       "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
              in
              Code:
              <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
                      "http://www.w3.org/TR/html4/loose.dtd">
              Dann solltest du dich aber über die Unterschiede zwischen HTML <-> XHTML und "strict" <-> "transitional" informieren und dir den "Doctype" aussuchen der deinen Bedürfnissen entspricht.

              Grüße, Lucien...

              P.S. Der SelfHTML Validator ersetzt natürlich nicht einen anschliessenden Besuch des W3C Validators, aber er gibt dir für den Anfang versträndlichere Meldungen und auch direkt Verweise zu Erklärungen bei SelfHTML.

              Kommentar


              • #8
                Vor allem mach mal die Tags zu ( z.B. <img ... /> oder
                ) und so Sachen wie heigth=" 6" müssen wohl auch nicht sein! Dann pack einfach mal das border:0px in dein CSS für Imgs rein... spart Schreibarbeit und vor allem Traffic und Ladezeit!

                Kommentar

                Lädt...
                X