Ankündigung

Einklappen
Keine Ankündigung bisher.

Darstellungsprobleme bei IE

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Darstellungsprobleme bei IE

    Tja, dei IE ist halt schei... :wink: Hab folgende 2 Probleme, die FF und O hervorragen meistern:

    Ich habe via CSS ausdrücklich gewünscht, dass meine Links bei jedem Ereignis immer grau sein sollen. Aber beim klicken blinken sie dann doch mal Blau (bzw. Lila) auf, aber nur für einen kurzen Moment. Hier die CSS Vereinbarung:
    Code:
    a:link {
    color : #c0c0c0;
    text-decoration : none;
    }
    a:visited {
    color : #c0c0c0;
    text-decoration : none;
    }
    a:active {
    color : #c0c0c0;
    text-decoration : none;
    }
    a:hover {
    color : #c0c0c0;
    text-decoration : none;
    }
    Ich nutze Tabellendesign, und habe der ersten Spalte ein Hintergrundbil verliehen. Es ist 600x200px groß und PNG. Der Tabelle habe ich dieselben Maße gegeben, so dass eigentlich alles passen müsste. Tut es auch, aber nicht im IE: Die Breite ist Korrekt, aber die Tabelle ist zu lang. Das Bild unten nochmal an. Hier der Code:
    Code:
    <td style="height:200px; text-align:right; color:#545454; background-image:url(img/header.png); font-family:trebuchet ms; font-size:30px;">
    Danke für Hilfe, Lucas.


  • #2
    Hallo? Ist die Frage so schwer? :wink:

    Kommentar


    • #3
      Zu deinem ersten CSS-Problem :

      Bitte hier mal schauen : Pseudoklassen für Verweise

      1. Eine "Pseudoklasse" fehlt
      2. Reihenfolge beachten

      Wenn die Fortmatierung für jede Klasse gleich sein soll, kannst du das auch "kürzer" notieren:

      Code:
         a:link, a:visited, a:hover, a:active, a:focus
         {
            color:#c0c0c0;
            text-decoration:none; 
         }
      ToolsTool - Online (SEO-)Tools im Browser gleichzeitig starten ...

      Kommentar


      • #4
        ...

        Kommentar


        • #5
          1) valide-buttons sind zwar schön, aber validieren will w3c deine seite nicht *g*
          2) im IE sind bei mir alle Links egal wie und wann grau
          3) 240 kb für das bild in png ? ein jpeg vernünftig komprimiert tut hier seinen zweck besser
          4) lager mal dein css vernünftig aus und arbeite nicht überall mit style="", dann kann man auch mal eben im FF mit dem developerbar testen und rumprobieren um dir zu helfen
          5) hinter 0-werte in css gehört keine angabe über den typ:
          Code:
          border:0px;
          sollte doch bitte border: 0; sein
          6) ein
          Code:
          *
          {
          margin: 0;
          padding: 0;
          border: 0;
          }
          sollte in jeder css ganz oben stehen, damit werden margin, paddings und border erstmal alle auf 0 gesetzt um in allen browsern ein etwa gleiches aussehen zu erleichtern.

          mfg
          robo47
          robo47.net - Blog, Codeschnipsel und mehr
          | Caching-Klassen und Opcode Caches in php | Robo47 Components - PHP Library extending Zend Framework

          Kommentar


          • #6
            m IE sind bei mir alle Links egal wie und wann grau
            Jo - bei mir auch ...
            ToolsTool - Online (SEO-)Tools im Browser gleichzeitig starten ...

            Kommentar


            • #7
              Zitat von robo47
              1) valide-buttons sind zwar schön, aber validieren will w3c deine seite nicht *g*
              Das war mal anders, aber seitdem ich die Umlaute wieder eingefügt habe... Wie kann ich ihm sagen, dass er die Umlaute einfach mitparst?
              Zitat von robo47
              2) im IE sind bei mir alle Links egal wie und wann grau
              Aha...
              Zitat von robo47
              3) 240 kb für das bild in png ? ein jpeg vernünftig komprimiert tut hier seinen zweck besser
              Hmm. Das änder ich demnächst... Thx.
              Zitat von robo47
              4) lager mal dein css vernünftig aus und arbeite nicht überall mit style="", dann kann man auch mal eben im FF mit dem developerbar testen und rumprobieren um dir zu helfen
              Wie soll ich einzelne Tags auslagern?!
              Zitat von robo47
              5) hinter 0-werte in css gehört keine angabe über den typ:
              Code:
              border:0px;
              Hat der Validator mir angekreidet als da keine Einheit stand.
              Zitat von robo47
              * {
              margin: 0;
              padding: 0;
              border: 0;
              }
              Jop, damit wäre das Problem dem Headerpic gelöst. Danke.

              Kommentar


              • #8
                robo47 hat Folgendes geschrieben:
                1) valide-buttons sind zwar schön, aber validieren will w3c deine seite nicht *g*

                Das war mal anders, aber seitdem ich die Umlaute wieder eingefügt habe... Wie kann ich ihm sagen, dass er die Umlaute einfach mitparst?

                Kommentar


                • #9
                  hallo?

                  Kommentar


                  • #10
                    'n morgen!
                    Welche IE-Version hast du (man muss ja was fragen)?
                    vielleicht 5?

                    Kommentar


                    • #11
                      6.0.2900...

                      Kommentar


                      • #12
                        Aber ich will ja das Problem mit dem Validator wissen... Mit den Umlauten...

                        Kommentar

                        Lädt...
                        X