Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] Java Login-Formular funktioniert mit 3 Browsern nicht.

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] Java Login-Formular funktioniert mit 3 Browsern nicht.

    Ein Bekannter muss sich in einem sehr bizarr gestalteten Webshop einloggen
    um Blumen zu bestellen. Beschwerd euch nicht wegen Sicherheit, etc. das ist ein holländischer, wahrscheinlich selbst geschusterter Webshop von einem kleinen Mann.

    Jedenfalls funktioniert das nicht. Ich habs in Opera, FF, IE probiert aber das Eingangsformular wird einfach nicht versendet. Beim IE ist diese Eingangsseite einfach nur blau.

    Habe mir den Source der Seite betrachtet und musste festellen das dort mehr mit Java Script statt mit konformen HTML gebastelt wurde. Sogar mögliche Fehlermeldungen (falls man sich versucht einzuloggen) sind im Code. Desweiteren habe ich zwar die merkwürdigen INPUTS für Name und Passwort entdeckt, aber der FORM Tag fehlt, darum ist in FF der submit Button "tot".

    Jedenfalls wurde mir gesagt das es Leute gibt die sich dort einloggen können. Bei meinen 3 Browsern funktionierts jedenfalls nicht.

    Liegt es vielleicht an meinen Sicherheitseinstellungen? Mit Firefox ist das formular tot. Früher ging es aber mit dem IE? Wo is das mit den Sicherheitseinstellungen und dem IE?

    Zum Shop http://217.21.248.185/webshop/


  • #2
    Hier werden sog. "Web-Services" (SOAP,WSDL) verwurstelt, daher läuft diese Geschichte nur auf dem IE (>=5.0).

    Welche IE-Version verwendest du ?

    Hab die von dir gepostete Shop-URL im IE (6.0.2x) mal ausprobiert. Bekomme den Passwort-Dialog (.NET-Style) ohne weiteres angezeigt. Geb ich "irgendwas" ein und schick das Dingen wech - kömmt nach'ner kurzen Weile der "User/Passwort falsch"- Hinweis.

    Die Sicherheitseinstellungen meines IE sind "normal", musste nichts "ungewöhnliches" extra aktiviert/freigegeben werden, um den Login-Dialog sichtbar zu machen.

    Sind die Zugangsdaten korrekt ? (Aber soweit kommst du ja auf dem IE ja gar nicht...?)

    Ist im übrigen kein "selbst geschusterter Webshop von einem kleinen Mann". Wer das Dingen gebaut hat, steht im Quellcode.

    Mal ein Link zu "Web-Services" , bzw. einigen Funktionen/Methoden aus den Sourcen.
    ToolsTool - Online (SEO-)Tools im Browser gleichzeitig starten ...

    Kommentar


    • #3
      Also ich hab den IE 6 und da ist alles blau.
      So und wenn ein Webshop was auch immer der für Services nutzt nur im M$ Browser geht dann ist das Müll. Ich hab von .net und dem Kram keine Ahnung, allerdings sieht ein normales, konformes Formular nicht so aus wie in diesem Shop soviel weiß ich und das man diesen Java Script Mist serverseitig mit PHP besser hinkriegt weiß ich auch.

      Dann ist es eben kein kleiner Mann sondern ne Handvoll Zwerge, die keine Ahnung von Forms haben. Wie auch immer habs in Opera, etc. getestet und nichts geht.

      EDIT: Oooh...ich hab mal Java Script aktiviert und seh nun das Fenster. Allerdings beim einloggen bekomm ich ne Meldung
      Client SOAP not available NULL.

      Kommentar


      • #4
        Etwas OT, aber was ich hier so lese ...
        Da stelle ich mir doch die Frage, warum sich der Bekannte seine Blumen nicht woanders bestellt.
        Zumal schon das Login-Fenster etwas komisch aussieht - sprich unseriös.

        Kommentar


        • #5
          Zitat von CIX88
          Zumal schon das Login-Fenster etwas komisch aussieht - sprich unseriös.


          Du wirst lachen, aber dass ist so'n Standard-Layout/Design der ".NET" - Applikationen. Soll sich wohl am "Look and Feel" von Windoof orientieren.
          ToolsTool - Online (SEO-)Tools im Browser gleichzeitig starten ...

          Kommentar


          • #6
            Ups -> starken Kaffee holen ...

            Kommentar

            Lädt...
            X