Ankündigung

Einklappen
Keine Ankündigung bisher.

phpMyAdmin Umlaute

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • phpMyAdmin Umlaute

    Hallo,

    wie der Titel schon fast sagt habe ich ein Problem mit phpMyAdmin und Umlauten.

    Bisher habe ich fast alle Datensätze über eigene masken verwaltet in utf-8.
    Hat beim aus und ein lesen auch funktioniert.

    Nur wenn ich mir phpMyAdmin im Browser öffne sehe ich Umlaut Fehler.
    So der Brwoser ist aber auch utf-8:
    Code:
    Variable_name Value
                         collation_connection     utf8_unicode_ci
                         collation_database     utf8_unicode_ci 
                         collation_server     latin1_swedish_ci
    Code:
    Variable_name Value
                            character_set_client     utf8
                            character_set_connection     utf8
                            character_set_database     utf8
                            character_set_filesystem     binary
                            character_set_results     utf8
                            character_set_server     latin1
                            character_set_system     utf8
                            character_sets_dir     /usr/share/mysql/charsets/
    Was muss sich ändern dass sich nur für die Kommunikation mit dem Browser-Client ändert?!? (alles andere geht ja)

    Danke euch
    Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so


  • #2
    Bei phpMyAdmin hatte ich bisher keine Probleme mit Zeichensätzen. Bist du auch sicher, dass die Daten korrekt in der DB stehen? Wie sieht so ein Umlautfehler aus?
    "Mein Name ist Lohse, ich kaufe hier ein."

    Kommentar


    • #3
      Also das ein und auslesen erfolgt über utf8 php bzw. html Dateien.

      PHP-Code:
      header("Content-Type: text/html; charset=UTF-8"); //ISO-8859-15
      echo '<?xml version="1.0" encoding="UTF-8"?>' . "\n";

      ....

      <meta http-equiv="content-type" content="text/html; charset=utf-8" />
      für -> für
      Ich kann natürlich auch Datensätze über phpMyAdmin einfügen, die werden auch richtig angezeigt, hat aber Fehler auf der Webseite zutun.

      Auf dem gleichen Server betreibe ich auch phpBB Foren.
      Gleiches Problem.
      Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so

      Kommentar


      • #4
        ü ist ein Zeichen dafür, dass ein Multibytezeichen als (mehrere) Singlebytezeichen dargestellt wird. Jetzt stellt sich die Frage, warum. Hast du das im Browser so festgelegt?
        "Mein Name ist Lohse, ich kaufe hier ein."

        Kommentar


        • #5
          Nein, eben nicht. Egal ob mit IE oder FF oder anderem Browser. Immer gleiches Problem!
          Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so

          Kommentar


          • #6
            PHP-Code:
            SET NAMES utf8 
            hilft leider auch net
            Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so

            Kommentar


            • #7
              So ganz klar ist mir nicht was das Problem ist. Lass doch mal phpMyAdmin aussen vor, kannst du Daten mit Sonderzeichen und Umlauten korrekt in UTF-8 eintragen und wieder auslesen?
              "Mein Name ist Lohse, ich kaufe hier ein."

              Kommentar


              • #8
                Zitat von AllOnline Beitrag anzeigen
                Bisher habe ich fast alle Datensätze über eigene masken verwaltet in utf-8.
                Hat beim aus und ein lesen auch funktioniert.
                Mein Problem ist, das ich für manche Sachen keine extra Maske programmieren will, und Datensätze über PMA editieren will und das geht nur mit richtigen Umlauten!
                Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so

                Kommentar


                • #9
                  Dann gibt's eigentlich nur zwei Möglichkeiten:

                  - Du machst beim Eintragen und Auslesen was falsch hinsichtlich des Umgangs mit der Zeichenkodierung, so dass es sich im Endeffekt gegenseitig wieder „aufhebt“; oder
                  - du hast im PMA noch irgendwas nicht korrekt eingestellt.

                  Kommentar


                  • #10
                    Normalerweise fand zu irgendeiner Zeit eine Kommunikation zwischen PHP und Datenbank statt, zu der die Zeichensätze noch verschieden waren. PHP-seitig kann das dabei ein falsches Encoding des Scripts selbst oder eine falsche DB-Connection oder eine falsche Formularübergabe sein.

                    Äußern tut sich das dadurch, dass (solange die Gesamtkonstellation erhalten bleibt) PHP mit den Daten vernünftig arbeiten kann, aber die Daten in der DB nicht in dem Zeichensatz eingetragen sind, auf den das DB-Setting gesetzt ist.

                    Machen kannst Du nur: Konsequente Umsetzung von UTF-8 überall (bzw. gewünschten Zeichensatz, UTF-8 ist aber zu empfehlen) _und_ Konvertierung der Daten in der DB in den entspr. Datensatz (Alternativ Neueintragen aller Daten in die DB).
                    --

                    „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
                    Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


                    --

                    Kommentar


                    • #11
                      Kann es den sein das ein Forum wzB phpBB den Fehler auch hat?!
                      Vor allem arbeite ich in php nicht mit utf8 en/decode.
                      Ich übergebe und übernehme Daten in und aus php/html Dateien die definitiv in utf8 an den Browser senden.
                      Der Quellcode wird auch in utf8 geschrieben.

                      An den oben genannten Einstellungen von PMA ist nichts falsch?

                      Danke schon mal für die Hilfe!
                      Wer Fehler sucht wird immer welche finden und manche motzen einfach nur so

                      Kommentar

                      Lädt...
                      X