Ankündigung

Einklappen
Keine Ankündigung bisher.

Keine Verbindung zur DB mit Linux (SuSe)

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Keine Verbindung zur DB mit Linux (SuSe)

    Hallo Leute,

    ich weiß hier einfach nicht weiter:

    Ich habe eine Datei "connect.php" die in die meisten PHP-Dateien integriert wird (per include) um eben die Verbindung zur DB herzustellen.

    Unter Windows: XAMPP installiert, DB importiert, Benutzer erstellt...funktioniert

    Unter Linux: XAMPP installiert, DB importiert, Benutzer erstellt...keine DB Daten und auch keine Verbindung zur DB.

    Nehme ich die Dateien unter Linux und packe sie auf den Windows Rechner, läufts?!

    Da ich von Linux keine große Ahnung habe aber es darauf laufen muss!, hoffe ich ihr könnt mir weiterhelfen!


    Danke euch


  • #2
    So können wir dir kaum helfen. Gibts irgendwelche Fehlermeldungen? Wie importierst du? Kopierst du die Dateien vom Windowsrechner auf den Linuxrechner?

    Kommentar


    • #3
      Fehlermeldung: Warning: mysql_connect() function.mysql-connect : Access denied for user'adm'@'localhost' ( using password: YES ) in /opt/lampp/htdocs/connect.php on line 8 Der Server kann nicht erreicht werden.

      Problem dabei: die Daten stimmen zu 99%

      Import: neue DB erstellen und Tabellen über ein sql-File importieren ( phpmyadmin )

      Und mit kopieren meine ich: Per copy&paste über einen USB-Stick


      Danke für die schnelle Antowrt

      Kommentar


      • #4
        Import über phpmyadmin? Ja dann scheint doch der SQL Server und PHP zu funktionieren ...

        Kommentar


        • #5
          Zitat von frustrated Beitrag anzeigen
          Fehlermeldung: Warning: mysql_connect() function.mysql-connect : Access denied for user'adm'@'localhost' ( using password: YES ) in /opt/lampp/htdocs/connect.php on line 8 Der Server kann nicht erreicht werden.

          Problem dabei: die Daten stimmen zu 99%
          Tja, dann ist es in diesem Falle wohl das verbleibende eine Prozent.

          Kommentar


          • #6
            Die Angaben waren zu 100% richtig

            Wenn ich den DB-Benutzer von "Jeder Host" auf "Localhost" umstelle funktioniert es, stelle ich es zurück, nicht mehr. Unter Windows lief es auch unter "Jeder Host". Wieso ist das so?

            Kommentar


            • #7
              Zitat von frustrated Beitrag anzeigen
              Wenn ich den DB-Benutzer von "Jeder Host" auf "Localhost" umstelle funktioniert es
              Damit meinst du, von welchen Rechnern aus die DB Zugriffe erlaubt?

              Drücke dich bitte so präzise wie möglich aus.

              Wie das jetzt zu
              Access denied for user'adm'@'localhost'
              passen soll, kann ich aber gerade nicht erkennen.

              Unter Windows lief es auch unter "Jeder Host". Wieso ist das so?
              Vielleicht, weil die DB so konfiguriert ist, dass sie keine Abfragen von außerhalb annehmen mag.

              Kommentar


              • #8
                Schau mal in der my.cnf nach einem bind-address
                sigpic

                Kommentar

                Lädt...
                X