Ankündigung

Einklappen
Keine Ankündigung bisher.

Parameter der mysql.exe richtig übergeben

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Parameter der mysql.exe richtig übergeben

    Hallo


    Ich exportiere per bat bestimmte dateien


    klappt auch wunderbar, aber jetzt brauche ich das file für die weiterverarbeitung mit einem feldtrennzeichen ";" (zurzeit habe ich einen tab. schritt dazwischen).


    ich hab jetzt schon 1,5 stunden nur probiert und gegooglet aber ich finde einfach nicht´s (mit der hilfedatei kann ich leider auch nicht anfangen)


    kann mir da einer einen tipp geben.


    D:\Finex\FinEx\Dat\Config\mysql.exe -u root -pPasswort -h localhost -C SDatWP <D:\Finex\FinEx\Dat\Config\export.sql > D:\Finex\FinEx\Dat\Config\Import\Text_Wertpa pierblockT.txt



    gruss

    pascal


  • #2
    Was genau hast du jetzt vor? Möchtest du eine SQL-Datei importieren? Oder eine CSV-Datei?

    Kommentar


    • #3
      ich eim export.sql steht nur das sql - statement zb: select * From testT

      dieses select ergebnis wird in die Text_WertpapierblockT.txt geschrieben
      das funkt. auch super, aber als trennzeichen zwischen den feldern ist ein tab. schritt u. den sollte ich jetzt duch ein semikolon ersetzen.

      jetzt ist meine frage wie kann ich dem aufruf
      mysql.exe -u root -pPasswort -h localhost -.....

      verändern damit ich als trennzeichen das semikolon bekomme?

      gruss
      pascal

      Kommentar


      • #4
        Warum imporierst du die Datei dann nicht einfach mit LOAD DATA INFILE?

        Kommentar


        • #5
          geht in meinem fall nicht (es geht hier um ein INTO OUTFILE) - ich brauch nur die hilfe wie ich diesen satz zu verstehen hab. das steh in der hilfe dazu?



          -g, --no-named-commands
          Named commands are disabled. Use \* form only, or use
          named commands only in the beginning of a line ending
          with a semicolon ( Since version 10.9 the client now
          starts with this option ENABLED by default! Disable with
          '-G'. Long format commands still work from the first
          line. WARNING: option deprecated; use
          --disable-named-commands instead.



          gruss pascal

          Kommentar


          • #6
            Ich hoffe ich habe dein Problem jetzt verstanden: Du kannst bei einem SELECT INTO OUTFILE angeben, dass du die Daten mit einem ; getrennt haben möchtest (FIELDS TERMINATED BY ';').

            Kommentar

            Lädt...
            X