Ankündigung

Einklappen
Keine Ankündigung bisher.

MySQL auf vServer neu kompilieren

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • MySQL auf vServer neu kompilieren

    Hi Leute,

    hab folgendes Problem:

    Auf meinem neuen vserver bei server4you läuft Suse 9 mit MySQL 4. Für meine Arbeit mit dem Server benötige ich unbedingt die Möglichkeit, per csv-Upload Daten in die DBs zu importieren. Mein Problem besteht nun darin, dass dies standardmäßig auf diesem Server nicht möglich ist. Dafür müsste ich den MySQl Server neu kompilieren, wo wir beim größten Problem wären, bei mir... Als Windows-Trottel ist für mich das Konsolen Handling absolutes Neuland und bis auf mich etwas durch die Dateistruktur zu fummeln und ein paar Dateien zu editieren kann ich nicht wirklich etwas damit anfangen.

    Die Support-Kunden wollen sage und schreibe 250€ dafür haben, deshalb möchte ich es selbst probieren. Sowohl mysql.com als auch die Suche im Forum haben mir aber nicht wirklich etwas gebracht, da ich fast bei 0 anfange.

    Konkret:
    Ich weiß, dass ich mit mit der configure Option "--with-local-infile" kompilieren muss, aber was davor?

    MySQL Server stoppen und/oder löschen? wenn ja wie?
    rpm draufspielen? wenn ja wie?
    make, make install - welches von beiden oder beide?
    ./configure mit welchen Parametern zusätzlich?

    Ich würde mich sehr freuen, wenn sich jemand erbarmen würde und mir dabei etwas helfen könnte, da ich nicht weiß, was ich sonst machen soll.

    Vielen Dank,

    Marcel
    Chuck Norris kennt die letzte Ziffer von Pi


  • #2
    Bezieht sich das auf http://dev.mysql.com/doc/mysql/en/load-data-local.html ?

    Kommentar


    • #3
      ja.

      ich weiß wie gesagt, was das problem ist und auf welche art man es beheben muss, nur nicht genau wie...
      Chuck Norris kennt die letzte Ziffer von Pi

      Kommentar


      • #4
        Ich wollte ja eigentlich nur wissen, ob es Deinem client wirklich nicht möglich ist, MYSQL_OPT_LOCAL_INFILE zu setzen, wie es zB hier beschrieben wird
        For the mysql command-line client, LOAD DATA LOCAL can be enabled by specifying the --local-infile[=1] option, or disabled with the --local-infile=0 option. Similarly, for mysqlimport, the --local or -L option enables local data file loading. In any case, successful use of a local loading operation requires that the server is enabled to allow it.
        Was ist denn Dein client?

        Hast Du einen weiteren, ähnlichen Rechner, auf dem Du erstmal ohne Risiko "üben" kannst? Ich mag mir die Anleitung zum Übersetzen von mysql aus den Quellen nicht wirklich ans Bein binden (sorry, ich hab einfach keine SuSE hier).
        Aber Du kannst hier mal loslesen http://dev.mysql.com/doc/mysql/en/in...ng-source.html
        Ein (evtl von SuSE angepasstes) Quellpaket gibt es vermutlich als srpm auf dem SuSE Installationsmedium.
        Leider kenne ich keine Möglichkeit, die configure Optionen aus einem bestehenden binary auszulesen (wie bei php mit phpinfo())

        Kommentar


        • #5
          danke für deinen hinweis, werd mal nach einem suse paket suchen und mein glück versuchen.

          das funzt ja so wie es ist auf dem aktuellen server. da wir jetzt allerdings vom einfachen webhosting bei 1und1 auf nen eigenen server umziehen, muss ich es hinbekommen, dass es dort auch läuft.

          es liegt auch definitiv an suse, dass hab ich in anderen Foren gelesen und das hat mir der spezi von server4free auch bestätigt - mysql auf nem suse system ignoriert sämtliche aufforderungen, diese option zu aktivieren, egal ob als root über konsole oder phpmyadmin.

          wenn ich den server abschieß, ist das aber kein großes problem, mit einem klick ist der wieder auf den status quo zurück gesetzt.

          kannst du mir denn sagen, wie ich den server anhalte und deinstalliere? war da nicht was mit NET STOP oder so?

          mfg,

          marcel
          Chuck Norris kennt die letzte Ziffer von Pi

          Kommentar


          • #6
            net stop ist win32.
            eher /etc/init.d/mysqld stop

            Kommentar

            Lädt...
            X