Ankündigung

Einklappen
Keine Ankündigung bisher.

PHPMyAdmin | mysqli_real_connet() error

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • PHPMyAdmin | mysqli_real_connet() error

    Hi,

    bin neu, denke aber, das ich in diesem Unterforum richtig bin.

    Ich habe auf meinem Server Nginx, Mariadb und PMA "from Source" laufen.
    Jetzt möchte ich mich bei PMA anmelden und erhalte die Meldung:

    mysqli_real_connect(): (HY000/2002): No such file or directory

    Bei meiner Google-Suche kamen schnell Ansätze bzgl. der mysql.sock.

    Meine Konfiguration sieht so aus:

    Bei PMA:
    Code:
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['port'] = '3306'; 
    $cfg['Servers'][$i]['socket'] = '/tmp/mysql.sock';
    $cfg['ServerDefault'] = 1; 
    $cfg['FilterLanguages'] = '^(de|en)';
    In PHP:
    Code:
    pdo_mysql.default_socket = /tmp/mysql.sock
    mysqli.default_port = 3306 
    mysqli.default_socket = /tmp/mysql.sock
    mysqli.default_host = localhost
    Mariadb Status:
    Code:
    ./mysql  Ver 15.1 Distrib 10.4.8-MariaDB, for Linux (x86_64) using readline 5.2
    
    Connection id:        8
    Current database:    
    Current user:        test@localhost
    SSL:            Not in use
    Current pager:        stdout
    Using outfile:        ''
    Using delimiter:    ;
    Server:            MariaDB
    Server version:        10.4.8-MariaDB Source distribution
    Protocol version:    10
    Connection:        Localhost via UNIX socket
    Server characterset:    latin1
    Db     characterset:    latin1
    Client characterset:    utf8
    Conn.  characterset:    utf8
    UNIX socket:        /tmp/mysql.sock
    Uptime:            27 min 2 sec
    Wenn ich, wie es im Netz zu diesem Problem oft zu lesen ist, "127.0.0.1" oder "localhost:3306" verwende, klappt es.
    Aber warum nicht mit dem Socket?

    Ich komme einfach nicht weiter...

    Kann mir da jemand weiterhelfen?


  • #2
    Könnte sein, dass ngnix und mariadb jeweils eigene /tmp haben (das Problem hatten wir letztens hier irgendwo)

    Pack das Socket mal wo anders hin. z.B. nach /var/run.

    Grüße.

    Kommentar


    • #3
      Zitat von php1704 Beitrag anzeigen
      Pack das Socket mal wo anders hin. z.B. nach /var/run.
      Sorry, war 2 Wochen im Urlaub.
      ... Danke, werd es bei nächster Gelegenheit mal testen.

      Kommentar


      • #4
        Hmmmm...
        bekomme es trotzdem nicht hin, egal wo das Socket liegt.
        Es muss ja letzten Endes ein Konfigurationsproblem sein, wenn es doch bei dir und anderen klappt.
        Obwohl das Problem im Netz nicht gerade selten anzutreffen ist und ständig als "Lösung" gesagt wird, man soll einfach
        "localhost" mit "127.0.0.1" ersetzen.

        Ich weiss grad echt nicht weiter. Warum verdammt nochmal ist so eine Kleinigkeit so heikel?
        Die Pfade sind gesetzt und ... es klappt doch nicht!

        Kommentar

        Lädt...
        X