Ankündigung

Einklappen
Keine Ankündigung bisher.

Hilfestellung bei mysql und phpmyadmin

Einklappen

Neue Werbung 2019

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Hilfestellung bei mysql und phpmyadmin

    moin!

    ich habe jetzt auf einem Win7 64bit-Rechner ein mySQL installiert und das Root-PWD vergeben wie auch einen User mit PWD angelegt.

    Jetzt geht es weiter und da "klemmt" es im Moment.

    In das Verzeichnis c:\phpmyadmin habe ich das gleichnamige Programm entpackt.

    Die config von Apache 2.4 wurde wie folgt ergänzt und neu gestartet:

    Alias /phpmyadmin/ "C:/phpMyAdmin/"
    <Directory "C:/phpMyAdmin">
    Options Indexes
    Allow from all
    </Directory>
    Jetzt ist ja noch die config von phpmyadmin anzupassen - dort steht jetzt folgendes:

    /* Authentication type */
    $cfg['Servers'][$i]['auth_type'] = 'http';
    /* Server parameters */
    $cfg['Servers'][$i]['host'] = 'localhost';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    $cfg['Servers'][$i]['AllowNoPassword'] = false;

    $cfg['Servers'][$i]['extension'] = 'mysql';
    $cfg['Servers'][$i]['auth_type'] = 'config';
    $cfg['Servers'][$i]['user'] = 'user';
    $cfg['Servers'][$i]['password'] = '';
    $cfg['Servers'][$i]['only_db'] = 'dbname';
    Das Problem ist der Name und der dbname. Ich bin mir noch nicht sicher was ich da eingtragen soll. Oder muss ich in meinem Falle erst mediawiki installieren damit ich den dbname habe. Ist alles so lange her.

    Wenn ich in den Browser http://localhost/phpmyadmin eingebe, dann müßte doch zumindest der Browser eine Seite anzeigen - auch wenn ich noch nicht richtig angemeldet werde. Aber da kommt nichts !

    Kann mir einer von Euch weiterhelfen`?

    Gruß Jan


  • #2
    https://www.apachefriends.org/de/index.html ... alles aus einer Hand ...

    Kommentar


    • #3
      In der Config von PMA musst du eigentlich nix zwingend anpassen. Standarmässig wird http auth und localhost verwendet.

      Das einfach weg:
      PHP-Code:
      $cfg['Servers'][$i]['extension'] = 'mysql';
      $cfg['Servers'][$i]['auth_type'] = 'config';
      $cfg['Servers'][$i]['user'] = 'user';
      $cfg['Servers'][$i]['password'] = '';
      $cfg['Servers'][$i]['only_db'] = 'dbname'
      Ansonsten Alias /phpmyadmin/ ist nicht "http://example.com/phpmyadmin" sondern "http://example.com/phpmyadmin/", aber eigentlich müsstest du ein 404 angezeigt bekommen.

      Kommentar


      • #4
        Moin !

        erst einmal danke für die Rückmeldung. Ich bekomme aber statt der 404 die 403 !

        Da muss sicherlich noch etwas rechtetechnisch geändert werden ?!?!?

        Gruß Jan

        Kommentar


        • #5
          Zugriff auch erlauben auf den Ordner.
          Zitat von nikosch
          Macht doch alle was Ihr wollt mit Eurem Billigscheiß. Von mir aus sollen alle Eure Server abrauchen.

          Kommentar


          • #6
            https://wiki.phpmyadmin.net/pma/Quick_Install
            [URL="https://gitter.im/php-de/chat?utm_source=share-link&utm_medium=link&utm_campaign=share-link"]PHP.de Gitter.im Chat[/URL] - [URL="https://raindrop.io/user/32178"]Meine öffentlichen Bookmarks[/URL] ← Ich habe dir geholfen ? [B][URL="https://www.amazon.de/gp/wishlist/348FHGUZWTNL0"]Beschenk mich[/URL][/B].

            Kommentar

            Lädt...
            X