Ankündigung

Einklappen
Keine Ankündigung bisher.

[Erledigt] PHP Fehleranzeige verhindern

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Erledigt] PHP Fehleranzeige verhindern

    Hallo zusammen!

    ich bin neu hier und habe weder in der Suche, noch im wiki etwas zur Loesung meines Problems gefunden.

    Ich fange mal mit den technischen Grundlagen an:
    • Debian (wheezy)
    • Apache 2.2.22 (Debian)
    • php Version 5.4.0-2
    • MySQL Version 5.1.61-2
    Es sind virtuelle Server fuer den Apachen angelegt, auf denen Joomla CMS laufen und auf einem die, zugegebenerweise etwas veralteten, Psychostats.
    Die Instanzen liefen bisher problemlos.
    Kuerzlich gab es dann ein Update der PHP Version, die mittels apt-get installiert wurde. Hier wurde aber, auf Nachfrage, auf die bestehende, editierte php.ini zurueckgegriffen.
    Die Joomla CMS sind davon scheinbar unbeeinflusst, zumal man ja bei diesen CMS ohnehinschon das Anzeigen von Fehlermeldungen begrenzen muss.
    Die PsychoStats produzieren jetzt beim Aufruf der Seite folgende Fehleranzeigen:
    Code:
    Strict Standards: Non-static method PsychoStats::create() should not be called statically in /var/www/stats/includes/common.php on line 102
    Strict Standards: Non-static method PsychoDB::create() should not be called statically in /var/www/stats/includes/class_PS.php on line 65
    Diese erscheinen jetzt ueber jeder Seite der PsychoStats.
    Code:
    Warning: date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in /var/www/stats/includes/CMS/functions.php on line 142
    Diese Fehlermeldung erscheint, wenn man bestimmte Datensaetze abruft.

    Die, meiner Meinung nach, relevanten PHP Einstellungen:
    Code:
    display_errors	Off
    display_startup_errors	Off
    error_reporting	24575
    ignore_repeated_errors	Off
    Meine Frage ist nun: Gibt es eine Moeglichkeit diese Fehleranzeige beim Aufruf der Seite zu unterbinden?
    Wenn ja, kann ich diese Einstellungen auf diesen einen virtuellen Host, mittels .htaccess begrenzen?

    Vielen Dank schon einmal fuer die Muehe.

    viele Gruesse

    Draal


  • #2
    Zuallererst solltest Du überlegen, ob Du die Fehler nicht fixen kannst, statt sie nur auszublenden. Vielleicht durch Einspielen eines Bugfix oder einer neuen Version?

    Strict Meldungen kommen häufiger bei php4-kompatiblen Anwendungen vor. Sind auch nicht gaaanz so problematisch.

    timezone settings solltest Du auf jeden Fall setzen. Folge einfach dem Hinweis in der Meldung. Es gibt verschiedene Wege, dieses Setting vorzunehmen. Im Manual findest Du auch Hinweise. Vielleicht bietet auch Joomla*) eine Konfiguration, die Du noch nicht gefunden hast.

    Erst dann solltest Du die Stufe von error_reporting runterstellen (Manual) oder display_errors auf off stellen (Manual!)


    [edit]

    *) Psychostats - Verlesen.
    --

    „Emoticons machen einen Beitrag etwas freundlicher. Deine wirken zwar fachlich richtig sein, aber meist ziemlich uninteressant.
    Wenn man nur Text sieht, haben viele junge Entwickler keine interesse, diese stumpfen Texte zu lesen.“


    --

    Kommentar


    • #3
      Hallo nikosch

      Zitat von nikosch Beitrag anzeigen
      Zuallererst solltest Du überlegen, ob Du die Fehler nicht fixen kannst, statt sie nur auszublenden. Vielleicht durch Einspielen eines Bugfix oder einer neuen Version?
      Leider gibt es fuer die PsychoStats keinen Support mehr. Das Projekt wurde eingestellt. Eine wirkliche Alternative konnte ich noch nicht finden.

      Prinzipiell gebe ich Dir Recht die beschriebenen Fehler zu fixen, allerdings benoetige ich da meine Zeit. Letztendlich moechte ich mir nicht die Logfiles mit dererlei Meldungen zutexten lassen.

      Zitat von nikosch Beitrag anzeigen
      timezone settings solltest Du auf jeden Fall setzen. Folge einfach dem Hinweis in der Meldung. Es gibt verschiedene Wege, dieses Setting vorzunehmen. Im Manual findest Du auch Hinweise. Vielleicht bietet auch Joomla*) eine Konfiguration, die Du noch nicht gefunden hast.
      Diesen Fehler konnte ich bereits fixen. Die date.timezone habe ich in der php.ini auskommentiert und definiert.

      Zitat von nikosch Beitrag anzeigen
      Erst dann solltest Du die Stufe von error_reporting runterstellen (Manual) oder display_errors auf off stellen (Manual!)
      Diese Einstellung ist so in der php.ini gesetzt. Die oben angezeigte common.php enthaelt jedoch folgende Eintraege:
      PHP-Code:
      // enable some sane error reporting (ignore notice errors) and turn off the magic.
      // we also want to to disable E_STRICT.
      error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);
      set_magic_quotes_runtime(0);
      /**/
      ini_set('display_errors''On');
      ini_set('log_errors''On');
      /**/ 
      Ich habe also zunaechst einmal

      ini_set('display_errors', 'On');

      auf Off gesetzt um die ersten beiden Fehlermeldungen zu stoppen. Erstaunlicherweise wurde das anscheinend bei der vorhergehenden php Version ignoriert.

      Vielen Dank nochmal fuer die Muehe. Ich erlaube mir mal das Thema auf erledigt zu setzen.

      viele Gruesse

      Draal

      Kommentar

      Lädt...
      X